'Installing Files' Purgatory

After finally getting the January installer to install to the HDD, I’m now stuck with every single attempted install (Dec USB, Dec HDD, Jan USB, Jan HDD) hung on ‘Installing files’. When I first attempted the ATV USB install a few weeks ago, it ended up here too, so following forum advice, I went and bought a Lexar 8GB USB stick, the fastest USB 2.0 the store had. Came home, ran the USB installer, everything worked great and was able to play with OSMC and decide to do a fresh install over my CB2 install. December HDD installed fine from the same USB stick, but got garbled with the Jan update. So tried reinstalling with Jan HDD several times eventually getting the HDD install to start, but resulting in ‘Installing files’. Trying to revert back to December HDD or any USB install I get the same result. I’d love to get a log file from the HDD but have no idea how to achieve that without a working USB install (via SSH) and would prefer not to have to buy another USB stick in the hopes that may work. I can understand there being chip issues preventing USB installs from completing, but I can’t understand that to also be the case for the HDD install (considering this happens well after the USB stick is removed from the process).

Hoping for some guidance here, ideally on how to extract some logs from the HDD. I don’t own the hardware at home that I could pull the HDD and plug it into something else…

Just went out and bought a SanDisk Cruzer USB stick. Same result for both HDD and USB install.


Some users have had issues with their systems being stuck at “installing files”.

Other than a incompatible USB stick, the other cause is usually people corrupting the USB stick before installation even starts.


  1. Did you safely eject the USB stick when you created it ?
  2. Did you make sure the ATV1 was powered down before you inserted the stick into the ATV ?

Depending on your answers… We may have to dig deeper.

Do you have a Linux machine that will allow you to edit the boot config file on a HFS+ partition ?
Windows can’t do it.

Thanks for the response, I’ve done this as described every time with no success. I also don’t have access to a Linux machine to do further investigation, all Windows at my abode. I’ve unfortunately gone back to OpenELEC (which hates my setup and requires a hard reboot every time I turn off my AVR which is doing HDMI passthrough) for a while until hopefully someone else experiences this and can help troubleshoot.

Using a Bootable Linux Live Image is a good way to run Linux temporarily without actually installing it.

Thanks Spinner, I’ll give this a go when I get some time.

Once you have a way of running Linux…
Here’s a link to a thread where I explained how use netcat to get installer output: