Installing latest version of sabnzbd to my vero 4K +

Right now I’m in a situation where I’m stuck with my iPad and iPhone and my vero 4K without access to a pc.

A few nights ago I managed to install and configure sabnzbd to run on my vero 4K and I control and add nzb files from my iPad or iPhone and it works relatively good considering I only have one usb thumb drive I use to download and unpack and store my stuff.

( I will buy 2 drives format them as ext and use them for unpacking and storage in the future)

But I found that I only installed version 2.3.6 and not the latest and greatest

When I try from SABnzbd - Wiki - Install SABnzbd for Unix/Linux

I get some errors about certificates and not being able to install the Repositorie.

I’m not very versed in Linux at all so if someone gives me some instructions please talk to me like I’m 5

Have you tried posting on their forums / community?

Without knowing the exact errors or being developers of this software, we are probably less able to help

Following the instructions here SABnzbd - Wiki - Ubuntu PPA Repository

I get this… see screenshot

More screenshots

OSMC isn’t based on Ubuntu – so doesn’t have these repositories.

You might need to compile from source if there is no Debian armhf repository.

1 Like

Ah yes I guess I was blind

Following this I got the old version installed: SABnzbd - Wiki - SABnzbd installation on Debian

But I can’t/ don’t know how to update it

You would need to follow the ‘From Source’ instructions. The Debian version usually lags and gets pinned to a specific version.

We’ll be moving to Debian Bullseye soon, which will have a newer version, but won’t be the latest and greatest.

1 Like

Since my current setup allows me to download the newest Linux isos over night and that’s the only thing that matters I won’t try to compile it myself right now although it probably would be some good practice.

Can I try without changing/ removing the current sabnzbd instance that’s working and running?

And remove the working version only once I know that the compiled one is working as intended?

So I kind of just went for it made a test folder and git cloned the sabnzbd stuff into it as per instruction from SABnzbd - Wiki - SABnzbd installation on Debian

First step went well than when I run ```

I got the msg that a python cheetah module is missing… when I tried to install it I got the msg it’s already installed and up to date…

See screenshot and don’t laugh to hard at my attempts of navigating through folders too much :rofl:

What am I doing wrong ?


The script is running python3, python-cheetah is for python2. Please try:

sudo apt-get install python3-cheetah

Thanks Tom.

Thanks Tom

That worked but now it wants me to install a modul called cherrypy

I tried with the same command you gave me but it didn’t work


sudo apt-get install python3-cherrypy3

Any additional packages, please try searching here:

Thanks Tom.

There is probably a ‘requirements.txt’ file where you can run pip3 install to install everything needed to run this Python application.

Is there a specific reason why you need the latest and greatest version?

To be honest not really I just figured I’ll try and figure this out I never did anything on linux and thought I’ll try and see how it goes although I know you guys have better things to do than to hold my hand

So I found the requirements file

But only got this far

I know you were mentioning pip3 but if I did pip3 install -r requirements.txt I got the error - bash pip3 command not found

sudo apt install python3-pip

will give you pip3

Installed pip3 but not much changed trying to do pip3 install -r requirements.txt

Made some progress…

Figured out Setup tools need updating and did that then run

Pip3 install-r requirements.txt again

And got this far

Because you’d then need to install the missing toolchain via sudo apt-get install build-essential

Respectfully, this is my last response to this post until you can answer my question:



1 Like

Hi Sam as I explained when you first asked few posts up I don’t really need the latest and greatest version although sabnzbd is being actively worked on and new parsers and obfuscation stuff is improved and worked on.

Although I’d lie if I said that the version I have now can’t handle stuff I throw at it.

As I said before I’m very inexperienced with Linux as you probably noticed but I have a lot of free time right now ( in quarantine) so I figured I’ll try to update my sabnzbd to the latest and greatest version and learn things on the way

And I realize I’m in way over my head and I realize you are busy with other stuff and don’t have time to hold my hand.

But I would still like to get this working not because I need it but because I’d like the experience and the good feeling of getting something done.

Installed build-essential and got a bit further when running pip3 install-r requirements.txt

You need to install the compiler tools (build-essential) package.

I would strongly suggest staying with the stable version because you will likely have problems updating and maintaining this package.