Installing swh-plugins and pulseaudio

Hello together,

I hope you are the right ones who can finally help me.

I have a problem, I’m struggling with it for over 1 year.

August 2020 I have my whole house equipped with a total of 4x Raspberry Pi 4. On all ran until today Libreelec with the Jellyfin addon.

I’ve been happy so far, the only thing that really bothers me is the constant volume control because a movie or an episode of a series is way too quiet or way too loud. Even worse is Youtube. Where felt every video has a difference of 20dB.

On the PC, I solve the problem with the swh-plugin for Pulseaudio. With this I can create a limiter that normalizes the sound on the fly.

I use this on the PC for years.

Since August 2020 I have already tried a thousand things. But unfortunately, these were all either “bungled” solutions or workarounds that are not intended for this and brought extreme quality losses. I also turned to Kodi and Libreelec developers and asked for help or solutions. I was disappointed, or told that this was a feature that only 0.1% of users would be interested in and therefore not worth the effort.

But now the smallest rescue! OSMC is finally released for Rpi4!

So installed directly. Connected via ssh and installed pulseaudio and swh-plugins with apt and configured an additional sink that uses the limiter.

And long story short:

  1. Sound output from OSMC is interrupted immediately.
  2. no pulseaudio devices are visible in Kodi

I hope you can help me to finally make this work!

Because when I think that a set cost around 100€ (rpi4, remote, power supply, case, sd card, etc) and had I known before that volume normalization is not possible, I would have just bought mini-pcs, which cost around 50€ used and are more powerful than any raspberry…

Sry! This text was translated with deepl, because my english is pretty poor. I hope I could get my problem across!

PS: And sry for the long text! :smiley:

Translated with www.DeepL.com/Translator (free version)

OSMC does not support pulseaudio. But a user has managed to make it work as told here.

You may also be able to find a plug-in for ALSA that does what you want.

Unfortunately, that did not help me. And I actually found a single(!!) “tutorial” for Alsa from 2009.

But as soon as I created the .asoundrc in the home folder, OSMC said goodbye with a “:(” on startup (got a real Windows 10 feeling at the sight…)

BUT! I finally found a solution or got an idea that really helped me.

Namely, I came up with the idea to simply google whether I x-any distribution on which I can then install Kodi by hand.

Then I found Archlinux ARM and installed it on a Raspberry Pi4. Then swh-plugins, Pulseaudio and Kodi. And configured Pulseaudio accordingly.

And voila! It runs flawless! Finally the same volume, no matter what is played.

The only problem that I could not solve (until now) is the fact that as soon as I turn on screen synchronization and sound-picture synchronization in Kodi, the sound stops exactly every 2-3 seconds for 0.5 seconds. But that is not so important, because these functions I do not use anyway.

Otherwise, everything runs exactly as it should!

Thanks anyway.

What would interest me incidentally, however, why not from the beginning on Pulseaudio / pipewire and instead uses the outdated ALSA?

Translated with www.DeepL.com/Translator (free version)

ALSA is not outdated. The RPi blog about pulseaudio is misleading. Pulseaudio sits on top of ALSA and AFAICT so does pipewire. Pipewire also seems to be work in progress.