Instant crash when playing OSMC on Rpi3

I have a problem with an instant crash (sad smiley screen), as soon as I play any file. Tried both local and over the network. I can’t seem to figure out what’s wrong. I can’t find something that seems to be the cause, in the logs.

Logs are here:

You have a banned add-on. The first thing to do would be to remove it.

I don’t see any attempt to start playing anything in the log, and you don’t have full debugging enabled.

Also, there is an odd error:

2020-01-21 19:13:38.231 T:1521189600   ERROR: CCurlFile::FillBuffer - Failed: Couldn't connect to server(7)
2020-01-21 19:13:38.231 T:1521189600   ERROR: CCurlFile::Open failed with code 0 for

I’m not sure what’s causing that. (EDIT: that error is being caused by another banned addon!)

You might try resetting Kodi and see if that helps.

systemctl stop mediacenter
mv .kodi
systemctl start mediacenter

and add one of your local sources and test again.

This doesn’t look right:

====================== advancedsettings.xml =================== C7hKmH1p
<?xml version="1.0" encoding="utf-8"?>
---------------------- advancedsettings.xml END --------------- C7hKmH1p

In the Kodi log it translates to:

<?xml version="1.0" encoding="utf-8" ?>
  <videolibrary />

Delete the file, restart mediacenter and see if that helps.

Alright, so I did some tidying up in the plugins. I think I have removed all banned plugins. I still get that strange CCurlFIle error anyway.
Here are new log files in debug mode. Trying to play testvideo.mkv from local storage. Still an instant crash when playing.

Starting on a new Kodi configuration, as bmillham suggested, does work. Also playing files work. So I think I’ll just go ahead and start fresh. It’s not a massive amount of work to reconfigure.

You didn’t remove all the banned addons. That’s where the CCurlFile error is coming from.

That’s probably the quickest and easiest fix instead of trying to clean up all the banned addons.

When you do that, make sure you don’t use any of those addons again. Besides the legality of it, you now know that many of those addons cause other issues :wink:

I don’t see in the log any reason for Kodi crashing unfortunately. I do however see on thing that could be a clue, you have service.watchdog enabled, and it appears to be watching for changes in the .kodi directory. This makes it trigger every time the kodi.log is written to. You could try removing service.watchdog and see if that helps.

Alright. I though I got them all. But I’ll go ahead and run a new config.

I have the old config saved. I might go back and test it again. The Watchdog plugin have been running for years, and working smoothly. Not saying that it isn’t the cause.