Insufficient space for Update to proceed

I have been running my Vero 2 for about 3 months and I am now getting an "insufficient space for Update to proceed error. I don’t have much installed on the Vero 2 (most of my media is stored on a network drive). I’ve tried running apt-get autoremove but that reported only about 26MB freed and the error persists. I ran updates manually (using both commands as recommended) and my version shows as OSMC July 2016.2016.07.01 but I still get the error when trying to run the OSMC update.

I have attempted to upload logs, but I’m not really clear on how that works.

Everything else seems to be working fine.


You can run df -h to see how a breakdown of space.

I noticed you posted before from last year in the Vero category. Are you a Vero 1 or Vero 2 customer? Things are a little bit different on these two devices.


I upgraded to a Vero 2 earlier this year. Here’s what I get using df -h:

Filesystem Size Used Avail Use% Mounted on
/dev/vero-nand/root 6.6G 6.2G 14M 100% /
devtmpfs 398M 0 398M 0% /dev
tmpfs 399M 31M 368M 8% /run
tmpfs 399M 0 399M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 399M 0 399M 0% /sys/fs/cgroup
tmpfs 80M 0 80M 0% /run/user/1000

6.6gb used. Have you got media stored on there? Some massive bloaty addon? Otherwise it could be the thumb nails cache, that can get large if you have a huge library.

Check /home/osmc/.kodi/temp
I had a problem with files with Asian characters which remained in the temp folder after scanning.
If that is not the issue you can install ncdu to hunt down the big files

Here’s a little trick:
du -sk * | sort -n

This will give you a list of all files and folders in a dir with the amount of space used, sorted by size.
You can add sudo in front of the du if you get any “permission denied” errors (e.g. for system folders).
Mind you that this can take a while on slower media with lots of files.
If there’s any hidden files in the dir, use “ls -A | xargs du -sk”
If you do not want to count stuff on different file systems, add -x
If you run from /, make sure to exclude stuff like /proc, /dev, /sys, etc.
-> ls -A | egrep -v ‘proc|sys|dev|run’ | sudo xargs du -skx | sort -n

You can then descend into the big dirs and repeat until you find the culprit which is hogging your disk space.


Finally had the time to look deeper into this (its been that kind of year) , and found a bunch of media files that somehow got copied into the temp directory. I deleted those out and now everything seems back to normal and I was able to succesfully run the update. Thanks everybody for the help and suggestions!

1 Like