Insufficient space to update warning POST update!


#1

kernel-4.2.3-2-osmc
2015.09-3

/dev/root 2.14G 65%
/boot 25M 69%
recovery 73M 92%
settings 25M 3%

I manually updated to 09-3 today before my scheduled check time and the auto check later stated there’s an update and it needs space.
So I clear and do a manual and it still says …insufficient space.
I have 2.1G free ?
How can there be a BIG update and why not state the required size ?

Also
The scheduling/updating function does not operate as I expect
My settings:
DAILY
18
0
WHEN IDLE

And under ‘when updating’ …
PROMPT FOR ALL ACTIONS

So with these settings I dont understand why it updates at any other time too when the Pi was not in use at 18:00 it also seems to download/attempt to download and then prompt for action. I’ve seen this happen on multiple builds now. Including when watching ‘live’ RT or youtube so I assume streaming via internet is considered ‘idle’ as it has minimal disk activity.


#2

You need at least 30MB free on your /boot partition - it is probably full of old kernels.

You can remove them (and any other packages no longer needed) like this:

sudo apt-get autoremove

In the next monthly update the system will start automatically removing old unneeded kernels during updates - they are not huge but they do add up once you have many of them…

The updater should never start checking for updates while you are watching video. For the update check I believe that the system is considered to be idle when not playing video and busy when playing video.

If the check time happens during video playback I’m not sure how quickly after playback is finished that it would begin the check.

cc @Karnage


#3

perfect!! thank you so much for this really handy tip! :slight_smile:


#4

Hi! I ran into the same problem!

Here is my disk usage:

osmc@osmc:~$ df -h Dateisystem Größe Benutzt Verf. Verw% Eingehängt auf devtmpfs 362M 0 362M 0% /dev tmpfs 367M 5,1M 362M 2% /run /dev/mmcblk0p10 2,0G 1,8G 28M 99% / tmpfs 367M 0 367M 0% /dev/shm tmpfs 5,0M 0 5,0M 0% /run/lock tmpfs 367M 0 367M 0% /sys/fs/cgroup /dev/mmcblk0p9 79M 32M 48M 40% /boot /dev/mmcblk0p1 477M 392M 85M 83% /media/RECOVERY /dev/mmcblk0p5 30M 440K 28M 2% /media/SETTINGS /dev/mmcblk0p7 1,9G 804M 1017M 45% /media/root /dev/mmcblk0p8 55G 22G 30G 42% /media/share /dev/mmcblk0p6 60M 6,7M 53M 12% /media/boot tmpfs 74M 0 74M 0% /run/user/1000

Any idea? I already tried to use your command but it was not enough. I already have 48M free on /boot =/


#5

But you only have 28M on /, which is not enough.

If you are using OSMC only, then ditch the NOOBS install


#6

No, I am using OSMC and Recalbox together. What kind of data in which folders are save to delete? /temp?


#7

I just wanted to comment that I was running into this issue as well.

What happened first was I noticed my rPi 3 was running slower than normal.

Then I had to hard reboot it at some point.

I logged in via SSH and ran updates. The thought of space issues never really crossed my mind.
Then for some reason I had lost my ability to control the device with Yatse. (Recreating the profile in Yatse fixed this).

Went to update the software from the UI since it said update available:
Got insufficient space warning.

Anyway I took the pi back to my desk and hooked it up with KB + Monitor. Found out the Disk is full.
Its been so long I am pretty sure I used an image and not n00bs,

SSH

osmc@osmc:~$ df -h
Filesystem      Size  Used Avail Use% Mounted on
devtmpfs        362M     0  362M   0% /dev
tmpfs           367M  5.0M  362M   2% /run
/dev/mmcblk0p2  3.4G  3.2G   57M  99% /
tmpfs           367M     0  367M   0% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           367M     0  367M   0% /sys/fs/cgroup
/dev/mmcblk0p1  240M   21M  219M   9% /boot
tmpfs            74M     0   74M   0% /run/user/1000

The apt-get autoremove ran, but did not fix the issue.

I tried running apt-get clean. (never used it before) Nothing happened.
Accept now there is space again.

osmc@osmc:~$ sudo apt-get clean
osmc@osmc:~$
osmc@osmc:~$
osmc@osmc:~$
osmc@osmc:~$
osmc@osmc:~$ sudo apt-get autoremove
Reading package lists… Done
Building dependency tree
Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
osmc@osmc:~$ df -h
Filesystem Size Used Avail Use% Mounted on
devtmpfs 362M 0 362M 0% /dev
tmpfs 367M 5.0M 362M 2% /run
/dev/mmcblk0p2 3.4G 2.8G 394M 88% /
tmpfs 367M 0 367M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 367M 0 367M 0% /sys/fs/cgroup
/dev/mmcblk0p1 240M 21M 219M 9% /boot
tmpfs 74M 0 74M 0% /run/user/1000

To get to the point. If you try autoremove and it doesn’t work try sudo apt-get clean

HTH someone,
-Wooley


#8

Since this was the top search result for me for this problem I’m adding a solution in case someone else can’t resolve the issue with the above commands:

I had put the SD card into a mac, and macOS immediately mounted the Boot partition and created a hidden 11 MB .Spotlight-V100 directory that pushed the free space just below the limit (this could easily be found by running sudo ncdu -x in /boot).

The solution was then to sudo rm -rf .Spotlight-V100/