Interface becomes weird in 3d mode

Hi!
I just installed OSMC on Raspberry Pi B+ and I am using it with my Samsung 3d TV.
The video is playing fine in 3d with full frame over/under. The problem I have is with the interface. When wearing the glasses it is annoyingly flickery and it is too big and awkward to be able to navigate (see photo).


Is there something I can do to fix this?
Thanks!

Hi @Simpqlicious, I assume that you’re trying to watch 3D movie from some of kodi’s addons (online stream). That is the main problem - your TV is “smart” enough to detect that there is 3D input and display it propperly but Kodi need specific file naming to work propperly with 3D movies and this lead to this “broken” UI. Most of the time streamed movies are with strange filenames - like random string and etc. - so you can’t do pretty much anything to fix it. Or if you’re trying to watch 3D movie from local storage (usb hdd, nas, etc.) you must be sure that your file’s are with propper name. At Kodi wiki you can find how to name your files. After that you must enable “Adjust Display Refresh Rate to match video”. You can find it under Settings -> Video -> Playback.

Hi and thanks for your reply!
I am watching an mkv movie that is stored locally. The TV has active 3d,
I’ll look into what you linked me!

Hi @Simpqlicious any news?

Hi there!
Sorry for my absence. It works perfectly :smile: