Intermittent, frequent video and audio stutter on some movies


#1

Hi folks,

Logs: https://paste.osmc.tv/ucuvicuzoh

I have had this issue for a long time so it isn’t necessarily related to the latest release/kernel. I’m just finally getting around to trying to resolve it. I thought after reading this, Playback Video - sound stuttering after March 5th Update, that it sounded like my issue, but I’m already on the latest build so not sure if it’s related.

As the topic states, some movies play with frequent 5-15s stutter/pauses.

I have the PI3 hdmi’d to a samsung TV, ethernet to my Freenas (where all media is stored).

I don’t seem to have this issue with TV shows, though that could be just codec related, not sure.

Any ideas?


#2

Hi,

I would considered kernel mounts, if possible nfs as you will get better throughput:

Also you consider adding a video cache:

https://kodi.wiki/view/HOW-TO:Modify_the_video_cache

Thanks Tom.


#3

Cheers Tom. Really appreciate the quick response. Will start with the video cache, and then look at the shares.

Do the logs point at bandwidth issues at all? Just wondering for my own knowledge what in the logs is pointing to the issue.

Thanks again!


#4

Post mediainfo of a problematic file


#5

This is Settings -> Player -> Videos -> Sync Playback to Display which is OFF by default? Believing the logs your TV/display provides the most common reslutions and frequency combinations. Any reason why you made it active?

Also, what brand and model is this TV/display? Can you use the benefit of audio passthrough for at least AC3 and DTS if possible? This would reduce the CPU utilization on your Pi 2. Currently this device has to transcode any audio format.


#6

@Tom_Doyle NFS ftw! Sorry, I should have done this when I initially set this up a year or so ago. I did this on my HTPC running Kodi, but not the Pi for some reason. Made a huge difference!

@JimKnopf This is only because I was testing random **** to see if it would make a difference. Cheers for the reminder. I’ll set these back to passthrough now (I have a Series 6 Samsung hdtv).

Thanks for the prompt advice, peeps! Much appreciated.


#7

So, look in your TV’s manual and find out what audio signals the TV can process, most likely PCM, AC3 and DTS. These I would forward as “audio passthrough”, then.

Also your speaker setting is 3.0 (would means channels left+right+center)?

I think it is worth a try to configure 2.0 which let you see an additional audio option where you can choose to transcode anything to AC3 which is not passthrough configured in your settings. Then it’s up to your TV to make the best out of the AC3 stream with your real speakers in/at the TV.

Wiki: Audio Setup and Information is a quite helpful article for this.


#8

@JimKnopf Cheers Set to 2.0 and also upped centre channel by 6dB on downmix because voice (centre) was too low. Movies are great now on this secondary tv through the Pi.

Thanks again for the info!