Internet access but no network

I haven’t been using my raspberry pi2 with osmc for a few days. today when i tried to use it i couldn’t use yatse or play movies from the local network. But i got internet connected and can play videos from youtube, any ideas of what might be wrong ?

I can see ip in system info and it says i’m connected and i get an mac adress. I can’t access anything on the network, and simply get an “Error 2: share not available” message. And when i try to open the files under videos it says “Invalid argument” and then “could not connect to network server”

Tried changing and resetting settings, rebooting ect. I’m out of ideas so anything would help

Device: Raspberry Pi2
Ram: 1024
Installation media: SDcard
Connection: Wifi
Power Supply Type:
Power specs:
Peripherals: TP-link wifi adapter
OSMC version: 0.9.9

Since you canplay internet files, the basic stuff is working, and it looks like a permissions problem on yor local net.
I would tackle that by logging in to the Pi via SSH, and using commands like ping and traceroute to localise the problem.
This sort of thing can usually be traced tochanges on your router or the system to which you are trying to connect.
Is that enough to get you started, or do you need more help?