Internet Connection Problem

New to Raspberry Pi and OSMC
Have set up Pi following instructions installing OSMC

Raspberry Pi 2 B
Software on SD card
Wired Connection to Router
HDMI to TV - no other devices etc

Problem - cannot get internet connection - internet status says - busy / Not connected

Have tried internet settings as DHCP - it gets an IP address and identifies the connector etc
Then tried with static IP and set the DNS’s to and (Goggle) still no change
have re-set at each change as well as wiped clean and re-loaded software a few times.

Have an older version of Kodi running on laptop (wireless) in the same network and it connects fine to internet with DHCP - so assume its not the network …

Should I be opening any ports on the router for it? or any other suggestions.


No port opening on router should be needed.
Have you tried the obvious - eg swapping ethernet cables, swapping router ports?
Usually the problems are with WiFi, not ethernet.

Hi Derek,
Thanks, have swapped ports on the router and the cable i’m using was being used for another device without issue so i’ve assumed its ok.
I guess its worth doing this again and using a different cable - will check tonight but i’m suspecting it wont make a difference.

what is better practice regarding static or dynamic IP and DNS servers?

1 Like

I’ve had ‘works perfectly with another device’ cables fail to make proper contact with the actual port contacts, so its as well to try a different cable.
I don’t think it matters whether the cable is straight or crossed - but have never verified it (mostly, these days, either will work).
Staic v Dynamic IP - depends on your local setup.Usually I start with Dynamic IP (router as DHCP), but often end up with static - mostly because I have a beast of a router which just will not take instruction to allocate an IP address based on the MAC.

It seems to me that you may have a bad NIC on the RPi or as said by dandnsmith a bad cable. Do you see link lights where the cable is plugged in?

If you see link lights while your having a play tonight, see if you can ping the RPi from a laptop etc. using the IP that is on the RPi. Just because you cannot get Internet working doesnt mean it is not working on the local network.

If you can ping the RPi, SSH to it and compare the output of ifconfig with ipconfig /all on your laptop (Assuming windows). Also try and ping an internet IP such as (Google DNS) or ( as you could have your DNS values incorrect or your gateway incorrect. If you can ping your laptop from the RPi, then is is definitely your gateway IP i.e. your ISP router IP.

When you are setting an IP statically on the RPi also ensure that the IP is not in use elsewhere on the network such as via DHCP; your internet router should be able to give you a list of IPs in use.

Thanks - link light are working, will try ping and SSH later on - IP add is not in use elsewhere (already checked)

Just though of something else that may be significant - dns on my router is set based on UnoTelly (using UnoTelly to get around netflix etc in South Africa) - can check the exact settings later but could this be an issue?
however i still come back to that i have kodi (older version) running on laptop within same network and it works 100% fine - so makes me think the router and settings are ok…


Hey Michael, the best course of action for you is to check local/intranet connectivity first and work backwards or hopefully forwards from there. If you can get access to the RPi via SSH, ping your gateway and then anything else that is live on your network via IP address. If that succeeds then try and ping an internet based IP as that will prove external access. If all that passes, then try the same via DNS i.e. “ping”. That should help you spot the issue

If the first step of SSH to the RPi fails, try and ping it, if you cant and the RPi definitely has an IP, you probably have a layer 1 issue, i.e. bad cable/ router NIC / RPi NIC.

I have OSMC installed for 6 months now on an RPi2 and I have had no issues with drivers to date either.

Finally regarding your router DNS entries, set the same DNS enties on your laptop statically and see what you can connect to. DNS works on a primary secondary basis, where if the primary is alive it usually ignores the secondary. If everything else is working on your LAN, I doubt if this is your issue, pinging a public website via IP would tell you either way as it will not use DNS, if it works and it wont via DNS/hostname well then it is a DNS issue.

Ok so didn’t have time to play last night but brought stuff to work and plugged in and its connected to the internet - so issue is either with cable or router set up… will de-bug later tonight

Thanks for assistance

I have the same Internet problem.

I have two SD-flashes - one With OPENelec that have no Internet problem and one flash with OSMC that reports this problem. Both flashed versions are the most recent. This indicates that there are no hardware problems.

I can log into OSMC using ssh, and then I can ping but it takes a long time before the replies start to arrive.
Something is wrong - but what?


Hi Per,
I eventually soled my issue - it turned out to be a vpn setting on my router that was messing with the internet connection.

Hi Per,

I’m not sure if you should create a new thread for this, but anyway can you tell us if it is a delay in presenting the ping response on the SSH terminal or is it a delay in response from If it is the second one, can you try and ping your gateway/ADSL router and see if it is the same and also check the CPU and RAM stats of your RPi to see if that is causing the delay?

Sorry for the slow reply…

I have now tested on two RPI2’s on the same LAN, only different ports on the same router.

If I type ping on osmc, it takes approximately 30 Seconds before the first ping appears - it is probably the DNS lookup that is slow. If I do ping then the response is immediate.

If I do the same on a raspian, both gives a prompt response, no apparent difference in timing.

osmc@osmc:~$ cat /etc/resolv.conf
Generated by Connection Manager

Both RPI’s have the same nameserver…


Do you see a delay if you set your DNS to ? (Google DNS)

No change.



from few days I’m having quite the same problem: in the system info I have a IP address with subnet mask and gateway, but both MAC address and internet are ‘busy’.
What does that mean?