IP address

Several months ago, I changed from a to a 192.168.1.* IP address. (NOTE: I use DHCP static assigns. ie. the omsc goes to the DHCP firewall server and is given the same IP address)

Everything worked fine. I could watch videos, login via ssh to the 192.168.1.* address etc.

Recently, I was checking my firewall, block logs and I noticed a strange thing.

I saw my OSMC at 192.168.1.X trying to send to

So i ssh’d successfully into 192.168.1.x.

Now the really strange thing. After doing some looking around and not finding anything conclusive, so I did a ifconfig .

osmc@osmc-mbr:/etc$ ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
ether b8:27:eb:88:a5:01 txqueuelen 1000 (Ethernet)
RX packets 5423 bytes 3032858 (2.8 MiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 5285 bytes 544602 (531.8 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

Remember, i have ssh into this at 192.168.1.x issued the command from inside and yet it’s reporting as

Never seen this before. Tried to delete it and rebooted but it keeps re-appearing. The other thing there is only one IP address, instead of Two so it’s not holding onto an old address as well as the newer one.

Never seen this before…puzzled. Any ideas of clues.

The OSMC is set for DHCP (my osmc - Network -Configure network manually). it shows the DHCP address of 192.168.1.x that it has been given.


A full log rather than a snippet, would make it easier to workout whats going on:

grab-logs -A

I’m assuming this isn’t your router, I would double check your router isn’t still advertising the old network range or if you have something like pihole on your network, this also others dhcp.

Thanks Tom.

Hmm, so the broadcast doesn’t seem to get updated always?

I blew it away and started over.

It’s working fine now and shows the correct IP address in ifconfig.

No more stuff in the firewall logs either.

I could mess with it but I am already backlogged on projects and honey do lists.

Thanks anyway.

Just for future advice. Ifconfig is not the best command to investigate ip addresses. Suggest to use ip addr next time