iPhone videos rotated again

It’s not the same one as before - It’s been sent to me by the same person though. I viewed one a month or so ago and it was OK but tried to view it again last week and it was rotated - I just picked a new one to upload to my dropbox for this thread but it works fine on my Pi - just not on my vero.

I created the log as instructed in the ‘How to create a useful…’ thread. It wouldn’t upload it so I saved to SD card and then ‘think’ I uploaded it correctly using hastebin and I also tried SSH using the paste-log command but I get an error there as well “Unable to upload log. Please check your internet connection.” In my router I do have all DNS blocks to block Google’s DNS - dunno if that may be an issue with this (I use UnoTelly to bypass DNS blocking on Netflix) Everything else works. The log file is around 75mb.

That’s massive. Suggest you reboot twice, then play the video and try to upload the log then.

The google DNS is the fallback DNS for OSMC so if your DHCP server does not distributed two DNS server entries this might become the main one due to a bug. So if you block it you might have more serious issues (like OSMC updates not working).


Didn’t see this before.

I’m back on Tuesday, and can check things out for you. Am I correct in assuming that https://dl.dropboxusercontent.com/u/9950473/404%20Harper%20progress%20video%2020160625.MOV does not play correctly on a Vero 1 running OSMC 2016.02-2.

If the clip is problematic on a V1, I’ll take a look.


Yes Sam, that is correct. It used to play before the latest update and plays fine on my Pi with OSMC and on my PC in VLC - it’s only the v1 Vero that is not working.

Interestingly, the thumbnail is rotated correctly.

I rebooted 3 times and then I was able to upload my log:


Thanks fzinken. Log now created and uploaded through OSMC/Vero as per my post to Sam. I have not had any issues with updating the Vero and I don’t seem to have any issues on my network. It’s a PITA I have to go to those lengths just to watch Netflix and I’m going to can it until they decide to stop playing games.

Thanks for your help.

Thanks, in a few days I will try your clip on a Vero 1 and let you know my findings.

I have an iPhone 6S at hand to replicate the problem. I clicked the Dropbox link in Firefox and it is displaying the wrong way. Will see why that is.


Thanks Sam - any news on this yet?


My flight got a bit delayed, so I haven’t had a chance to look at it yet. I’ve added it to my list, so I’ll make sure that provided it’s a simple fix (should be), I can get it in the July update.


Thanks Sam

Hi Sam - this wasn’t fixed last month will it be fixed in this months update?


I can replicate the problem, but I’m not sure how to resolve it at this time. It’s on my list and will be revisited when we rebase for Kodi Krypton (v17) shortly.


It’s weird that in my Pi it is fine - it’s only the Vero and only after a recent update. I don’t think it’s a Kodi issue but a Vero one.

Has this been addressed yet Sam? (I’ll check soon myself but my Vero hasn’t updated since September and I’m just now doing a manual update via SSH)

It should be resolved in a Krypton test build