iPlayer not work on some programs

I have just installed BBC iPlayer on my Vero 4K. I thought it was working OK when I tried it for the first time and selected from the first series that came up, which worked fine, but alas when I used the search feature to look for a BBC film, I was able to find it but it did not play. There was a note to look in log for more info.

Good suggestion but look where for what and how and what is going wrong.
I am living in Scotland and not using a vpn so, while Scotland is still in the UK I should be OK, so where am I going wrong? I didn’t get any request to sign in but didn’t see opportunity either.
Grateful for some guidance please.

There’s a fix for Inputstream Adaptive add-on and this issue might be causing your problem.

This will be fixed in Kodi v19 and we expect to publish test builds imminently.


Hi Sam,
Many thanks. I don’t know or recognize anything about Inputstream Adaptive add-on but am happy to take your work for it.
I am getting other symptoms which I do not understand. For example if I go to the series “The Young Montalbano” and select it, I only get series 1 episode 1, not an option to chose which episode to watch. It is as though there is a filter missing.
Any help welcome in due course and no rush but I am surprised that others have not run into this problem.

I think this is just an annoying characteristic of iPlayer. It’s the same on my TV’s built-in app.

You have to search for a programme title rather than through ‘highlights’ or other shortcuts.

1 Like