IPTV on Rpi 3 osmc not working

I bought a iptv package from Rapid IPTV. The streams work on VLC, random iOS apps and Kodi for PC but I cant seem to get it to work on my Raspberry pi 3 with OSMC installed on it. I bought and received the MPEG2 licence and entered it into the Rpi but that has not solved my problems.

I use the simple iptv pvr addon that comes with OSMC and enter my m3u link. It loads all the channels and I can see them in the live tv list. When I press a channel a “loading circle” appears for a second or two and then disappears and no stream starts.

Got any suggestions? Do I need to submit any logs?

Thank you in advance!

PS I’m a total beginner at this

In case anyone finds this post later, I found a solution that worked for me.

I setup the Tvheadend server on my Rpi with all my channels and used the Tvheadend client addon. The iptv simple client still does not work for me. Hope this helps someone in the same situation.

I have the same problem, can you explain how you setup TVHeadEnd ?
I get this error after it starts scanning:

  • scan no data, failed
    2016-08-09 13:24:27.000 subscription: 0009: “scan” unsubscribing

The URL works fine on my pc.

In case anyone finds this post later, I found another solution.
While I was trying with OSMC it was impossible for any channels to play.
They would load in the channels list but would fail.

I had to install XBian + PVR IPTV Simple Client.
Then I setup PVR IPTV Simple Client as usually.

After restarting, another problem appeared when I tried to load the m3u file remotely.
It wouldn’t scan for channels as it was failing to download the m3u file.

The solution was to download the m3u file manually, place it on my NAS and load it locally.
Now all the channels load and play.

Please note, this solution didn’t work on OSMC. I only got it to work on XBian.