IPTV on Vero 4k is BAD compared to Raspberry pi 3

I’ve had my V4k+ for a year now and have been really struggling with getting smooth IPTV playback on this device.

I have for months used a script to poll kodis status and determine if IPTV is playing or not on the V4k+ because having HW-acceleration enabled simply never works and results in video/audio being out of sync. I’ve had discussions about this in this thread before. Disabling HW-accelaration has worked with most IPTV streams that are lower res/bitrate, but the CPU usage is near 100% on all cores all the time.

All this time I thought this was due to “newer” kodi versions (since I haven’t had this issues on a rpi 3 running a 2021 OSMC install that I don’t wanna update), but today I decided I had to do something about it so I updated my V4k+ to 2023.12-1 and the issues persisted. I then installed the same OSMC version on a second raspberry pi 3 to compare and I’m having no issues. HW-accelaration is working and I have no issues with video/audio getting out of sync as described in the post above, it just works as intended.

Please devs, take a look at this as this is really breaking the experience. This must be a Vero specific issue

I don’t have access to any IPTV services. The first logical steps would be to provide logs.

It would also be good to confirm if recordings are affected to rule out a network issue.

I can provide logs from both systems for comparison. Would you like me to:

  1. enable debug logging
  2. start troublesome stream
  3. upload logs

missing something?

If recordings are affected or not is a little trickier since IPTV simple client has recordings turned off by default, and I have never had recordings enabled on any of my machines. Seems strange to enable this now. Both machines are on the same network connected to the same switch, going to the same router so logically network issues should affect both devices - I can exchange their respective ethernet cables if you’d like but I doubt that’s the issue since 4k high bitrate streams from local network drive are playing perfect on the V4k+. In fact everything I throw it at, except for IPTV, is playing perfect

It’s usually a good idea to reboot twice, after enabling debug logging and before reproducing the issue. That ensures that the logs don’t get too big to upload or to sift through.

If there is a playback problem I will need a recorded file to reproduce and investigate…

@angry.sardine thanks, will do this and post logs ASAP.

@sam_nazarko are you sure iptv simple client will record the stream as is and not save it in a different format? I’ll give a recording a try if you think it’s worth it

It won’t transcode the stream, no.

Ok, i tried enabling recordings but doesn’t seem recordings are supported with iptv simple client (anymore? Pretty sure I’ve seen this in previous versions? )

I enabled timeshift for all channels in the addon (rebooted), I looked in the pvr menu - recordings but I have no option to neither pause the stream nor record it.

Would using vlc to record the stream (if that’s even possible) be of any help if the client can’t record?

I’m not sure - I think that will transcode the stream.

Getting an error when trying to upload logs. I’ve disabled adblocker, I can scroll through the pasted text, but saving results in an error, what am I doing wrong?

logs too big?

How did you try to upload the logs?

Did you reboot twice?

Yes, rebooted twice on both machines prior to grabbing logs. Tried uploading by visiting https://paste.osmc.tv/ and pasting from Visual studio Code to browser.

Grabbed logs via SSH running grab-logs -A -C. Transferred the logs to my pc and replaced hostname and username/passwords with **removed*by*user** everything else untouched

Copy the modified file back to the Vero and try to upload it with paste-log <Filename>

Ok, so it’s a filesize limit:

osmc@vardagsrum:~$ paste-log /home/osmc/V4K_uploadlog.txt
Unable to upload log. Log file is too large. (40MB)

I can of course upload it somewhere else or remove the 100k-something rows related to import of playlist, channelgroups, ChannelGroupMember etc… which do you prefer?

I can mention I also tried recording a sample of the troublesome stream with VLC (no playback issues with VLC) but couldn’t get it to record a sample, so I took a screenshot of the codec_info, hope this can help with troubleshooting

Since no preference has been mentioned I uploaded the two debug-logs to Mega, hope this works for you otherwise let me know

Really not my intention to stress but since 3 days have passed without any comment I’m starting to get curious if anyone from the dev team is actually looking at this and if the logs I provided, and the way they are provided is useful, or is there anything I can do to help?

I don’t know anything about the situation here but I took your Vero log and cleaned it up to something that someone who does might be willing to look at (removed kodi.log.old and 27k+ lines of iptv m3u loading spam so 40MB became 696k :roll_eyes: )…


1 Like

Thanks, really appreciate it :blush:
Should I do the same with the rpi3 log then maybe?

I am not going to download 76MB of logs and wade through them.

Without a recording / sample I’m not sure how I am expected to investigate,

I don’t see how a log for a RPi is going to inform of anything on a Vero h/w decoder since they have nothing in common.

I don’t know if it would actually make a difference here but you might try setting refresh rate switching to always in Kodi’s player settings and in the PVR section for playback set fallback refresh to 50 fps. If you have the ability to cut down the number of channels your loading perhaps that would have some impact. I don’t know anything about iptv but I’d think that loading up so many channels can’t possibly come without a cost.