IPv6 on Vero 4k+ - is it disabled? (Losing internet connection)


#1

I think I read somewhere in a thread that was a year or two old, that ipv6 was disabled by default in the Vero. Is that still the case?

Reason I’m asking is that my Vero 4k+ disconnects from the internet
after it has been idle for a day or so (or just suspended). The Kodi internet information shows that the connection flips between Connected, Busy and Not Connected and the MAC address seems to have gone missing. A simple reboot sorts it out, but the same thing happens after a longer period of inactivity. I’ve changed DNS server settings and assigned a static IP address, but that’s not solved this.

I’ve read on Kodi forums that disabling IPv6 can help, hence my question.


#2

Hi,

Yes – IPv6 is disabled by default. The main motivation for this was that it caused issues on Raspberry Pi. We have disabled IPv6 at the Connection Manager (ConnMan) level.

Are you using Wired Ethernet? There’s a bug which can cause the connection to drop after a large period of inactivity. This has been solved and will be available in the next update

Sam


#3

Yes I am on wired. I’ll wait for the update then. It’s not a significant problem as it only happens after several hours of inactivity, including if I put Vero into sleep mode. I’ll set it on wireless overnight and see if that makes a difference.


#4

Just to confirm, December’s update seems to have fixed the wired Ethernet dropped connection after a long period of time on the 4k+. Thanks!


#5

Thanks – I’m glad to hear this. We had an IRQ issue with the RTL8211F adapter; but this is now resolved.

Sam


#6

Perhaps just keep an eye on this as I’ve just discovered my connection did get disconnected again (but after a couple of days of being on). No big deal as a reboot sorts it out.


#7

Can you attach a keyboard when it drops and check some things via the command line next time it happens?

The output of ifconfig would be useful.

Are you using the Suspend mode?

Sam


#8

It’s been powered on for a couple of days (not suspended). I’ll keep an eye out on it (you’ll need to let me know what to test though as I’m not very technical). It’s not a big issue though.


#9

A photo of the output of ifconfig would be interesting


#10

Ok. I’ll try and do that if it drops connection again. Thank you.


#11

Hmmm… I’ve checked ifconfig after network connection dropped and at the OSMC level it seems OK - ie still connected with an IP address assigned. It’s within Kodi itself that the IP drops after a long period of inactivity. I have OpenVPN always on (via Kodi) , so will disconnect that and test again to see what happens. I’ll also investigate this using wireless connection only. As I said, it’s not a huge issue and a quick reboot of Kodi always sorts this out.