Iqaudio not detected after Pi 3 switch


I’ve recently purchased a Pi 3 and upgraded a setup which had a Pi 2 plus Iqaudio Dac Plus running OSMC.

I’ve rab thr latest software update before switching out thr hardware. I’m using the same SD card as before.

I’ve tried changing the audio hardware card to “none” in Pi settings, rebooted, added back IQ Dac Plus and rebooted again. The Kodi audio settings don’t show the iqaudio card like it used to.

What can I do to help trouble shoot and confirm what is causing the issue?


@notshy keep rebooting should eventually work

Thanks for the reply!

“Keep rebooting” - do I need to keep on switching between IQ Audio vs None between each reboot or just keep rebooting with IQ Audio selected?


@notshy keep rebooting with iqaudio selected make sure you have the right dac selected that’s all I done


I’ve tried rebooting a number of times and also tried full power down and unplug. And still no joy.

I’m running squeezelite and the audio from that plays through the IQ Audio card fine so I know it’s not the hardware or core OS.

Are there any ideas how I can do any more trouble shooting?

@notshy check to see what you have in your config audio settings = should be dtoverlay=iqaudio-dacplus-overlay and NOT = ALSA: default (bcm 2835 ALSA bcm 2835 ALSA if its the alsa that’s there change that to dtoverlay dacplus like up above in your config settings via the osmc app


Yes that is the setting that I’ve been changing from “None” to “iqaudio-dacplus” between each boot. Even with setting it to on - it’s still not showing in the Kodi Audio Settings page.

If I turn that overlay to “None” then I do see ‘bcm 2835’ in Kodi Audio Settings. However when I set it to “iqaudio-dacplus” I am just left with ‘HDMI / Analogue / HDMI and Analogue’ in the Kodi Audio Settings and no mention of the IQ Card (which I had working before).


@notshy I recommend you send sam nazarko a message and pick his brain on this he knows a lot and should be able to help you on this matter thanks

Thanks for the recommendation. Sorry to pull you into a thread but @sam_nazarko do you know what this could be?

My IQ Audio card is working fine with Squeezelite but not working in OSMC (not showing in System Settings > Audio) since I made a hardware upgrade on the same SD card from a Pi 2 to a Pi 3.

Can I do any trouble shooting?

Still no luck with getting the IQ card to show up. Can I ask if anyone has any further ideas? It’s working in Linux as squeeze player is working fine.


what are the contents of your config txt ?