IR Remote not working with 05-2 update

I have a Vero4k and use a RC6 remote with the built-in IR receiver. This works fine with the 2017.04-1 software. I believe that it worked with 2017.05-1 update, but I am actually not sure in that I updated then went out of town for a week. I think that it was working to update to 2017.05-2, but now it is not working properly. I have to hit the button twice within ~1 sec to be registered. A single hit with nothing for over ~1 sec will do nothing. That is, if I hit buttons once every 2 sec, nothing happens. I ran irw and the issue shows up there, so it is something early in the process.

I remember an issue a long while ago where button presses were being duplicated and there was some method of filtering that out. I never had that problem, so I don’t remember the details.

If it helps, I uploaded all logs to

I should point out that I use a DirecTV remote and a custom lircd.conf file and custom Lirqmap.xml and custom remote.xml files. I tried plugging in a USB IR receiver and that works OK. It is just the built in receiver that is not working.

I reverted back to 2017.04-1 to make sure that it works. If does. I then updated to current version (2017.05-2) and it stopped working again. So, something is different between 04-1 and 05-2 that is causing the problem.

Further remote improvements are coming. Will let you know when I have something ready for testing.




Hopefully the issue is fixed now.

I’d appreciate it if you could test this and provide feedback before we release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb jessie-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.


This update works for me. I may be reading too much into this, but the remote response seems much snappier than before.

Great to hear, thanks for letting me know. I’ll make sure it’s working well for others
before making it part of the next update

Well, you broke it again in 2017-06.1. The local IR input on the Vero4k only registers a command if I double press the button. Is there an easy way of going back to 2017-05.3? Or better yet, getting this fixed?

We didn’t change remote subsystem between 2017.05-3 and 2017.06-1, so may be a different issue.
You can definitely download an older version, but won’t explain why your remote has stopped working.

As you say you’re using ‘an RC6 remote’ I assume you have set up the profile up yourself. If you have, check irrecord and mode2.

CC @smurphy @sniferx1 @dbmandrake @mlavende – remotes still working same as before?

That’s odd. It didn’t work in 2017.05-2, but did after I added the line in sources.list, and it worked when I upgraded to 2017.05-3, but now it is not working in 2017.06-1.

No need to make any changes to sources.list. I’d advise you remove the ‘jessie-devel’ line or you will receive unstable / preview updates.

You may have not rebooted after updating, which would explain this problem. Anyway – glad to hear it’s working now.

Sorry for the confusion. It is not working now. Well, actually, it is as I reverted back to 2017.04.1. The only other option in the installer is 2017.05-2 which didn’t work for me until I loaded the experimental build that you gave me. I removed that line in sources.list as soon as I rebooted. That was all old history.

So, it was working after the 2017.05-3 update, but not today’s 2017.06-1. I did reboot and it doesn’t matter. The remote will only register if I push the button twice in quick succession.

I am stuck at 2017.04-1 until this gets fixed.

See above. Did you record the profile?

Will also ask others to confirm if the remote is working as expected.

So, you think that there may be a slight timing difference between the two kernels? That’s an interesting thought. I won’t be able to check this out until the weekend. I don’t have free access to the system. This seems unlikely, as it can correctly recognize every key as long as it is pressed twice.

@sam_nazarko As per my post feedback when you release the fix post June update I also experienced the same and that’s why I said every 2 remote presses VERO4K doing ONE action. Given you told me this is the best you can do I accepted it.

As per forum feedback this used to work flawlessly until May Update and given you reverted all changes done I am not sure what else you can do…

I am used to this behaviour now and I am ok…

My forum Link which include the Video:
Latest VERO4K May release broken Remote IR Mapping for XBOX ONE / 360 Remotes - #41 by sam_nazarko


Yep – aware of this.

What’s strange is @jmkinny says it only regressed in the last update; so needs more investigation. Unfortunately I think if we fix this issue it may cause problems for other users. I’ll produce some more builds and see what can be done as long as you guys are willing to test.



I can test.

Great – will let you know when we’ve got something to try shortly

Er. When do you sleep? Or are there multiple people using your name?

Just me.

I get plenty of rest when no one is watching.

Can you post me the DirecTV remote’s config so I can investigate further?