IR remote problem

I’m trying to configure an universal IR remote with OSMC unsuccesfully. I have installed the diode receiver in the GPIO pins and it seems to work, but in Kodi I’m not able to make it working.
I’m using raspberry 4b and I installed again the last version of OSMC (20220308-osmc) with AEON Nox Silvo. CEC works but I would need to use it with the IR because of latency and customizations. For testing I disable CEC in kodi.

In the terminal I can see the key presses with:
mode2 -d /dev/lirc0 --driver default
so, it seems that the receiver is working in the raspberry.
But when I try to learn the keys with irrecord and then use the conf file in the OSMC menu, I can select it, but it doesn’t work. No response from the remote. I tried to use some of the existing conf files changing the universal remote profile and it doesn’t work neither.

The keys it learns look like this:
begin codes
KEY_UP 0x7B010000000213
KEY_DOWN 0x63010000000231
KEY_OK 0x60010000000231
KEY_LEFT 0xBF0100000001C9
I don’t know if there is a way to test the configuration file from the terminal. In the past with a small pc I could do that with irw, but now it doesn’t work. I think that with new ir module in the kernel some things are different.
I have tried many things unsuccesfully, any help or hint would be appreciated.
Thank you!

You could try use one of the profiles available in My OSMC.

Yes, I did. I used the one from a Samsung remote and programed the remote to emulate it, but no response.
It would be helpful a way to test in the terminal if the system recognizes the mappings of the conf file created with irrecord. So, press a key and display the maped key code, like before with irw. But I haven’t been able to make it working.

To use irw you will need to disable the lircd helper instances.

Are you using gpio-ir? This changes things a bit.

I think so. Sunday I did a fresh OSMC installation (20220308-osmc). I haven’t installed or changed anything, except the AENOX skin.
What I did after installation was to go to My OSMC → hardware, activate the GPIO in the pin 18 and disable CEC. With that the system respond to key presses in the terminal. I have checked the config-user.txt and this was added:
I assume that it is correct. But from this point I don’t see whats going on. Selecting the remote in My OSMC doesn’t work.

With disable the lircd helper, do you mean this?
sudo systemctl stop eventlircd
sudo systemctl stop lircd_helper@lirc0
I tried also to close kodi: sudo systemctl stop mediacenter
How could I actually test everything from irrecord to irw or whatever in the terminal? I’m not sure if I use the correct tools, or should I try something different.