IR remote receiver not recognizing keypresses

I have three brand new Vero 4k+ boxes. Two are working just fine but one is having issues with the IR remote. The problem box has issues just using the UI to browse through movies. Some keypresses are ignored while others act like I’m holding down the key and it responds by scrolling multiple lines at once.

I’ve searched the forum and I’ve seen complaints of similar issues while videos are playing and the IR issues appear to happen because the processor is overtaxed by trying to do too much. This is not the case here as nothing is playing when I’m trying to navigate the UI.

All three boxes are configured the same and all of them have the latest 10.1 update. I’ve tried using both the built-in IR receiver and the IR extender and the results are the same. I’m using Harmony remotes on all of the boxes and the profile I’m using is for a Media Center Extender. I’ve used that profile with several boxes that are running kodi and it has worked just fine. The RF remote works just fine on the problem box.

The fact that only one box out of three that were purchased at the same time has issues indicates a hardware problem. Can anyone think of anything else I might try? I’d just return the box but I’m in the U.S. and Chicago Electronics appear to be out of stock.

I uploaded logs to in case that helps.

Your using the same setup on the Harmony remote and LIRC profile on all three? If so the remote from the problem one works good on two but not the third? Is their sunlight shining on the IR sensor? If you swap the problem box into the other room does the problem still exist?

All are using the same setup. All three Harmony remotes work for the two working boxes and not on the one with the problem. Sunlight is not an issue. One of the steps I tried was to replace the non-working box with a working one in the same room where the non-working box was installed and the problem stayed with the problem box.


Are all Vero devices on the same version of OSMC?
You say they’re all on 10.1 but I assume you mean 2022.10-1.

CPU isn’t overloaded – but in recent updates we have an IRQ bug and we’re investigating this

If both the external and internal receiver are problematic, then I don’t think it’s going to be a hardware issue at all.

Can you upload a log from a device which works well and one that doesn’t?




You’re correct about the version being 2022.10-1. And both the internal IR and the IR extender show the same issue.

Log from the problem box:
Log from a working box:


Thanks John – I’ve also replied to your support ticket.

It’s late here now but I will get back to you properly by tomorrow evening,


Just to throw an option out there, I run my Harmonys through FLIRC USB adapters connected via a USB extension lead so the IR senser can be placed under the TV and the player can be out of sight. This gives me a more responsive control vs the built in IR on my Vero and I gain the ability to utilize long-press functions.

I hear what you’re saying. The included IR extender does that well enough for me and the responses to IR commands are usually immediate. I don’t really want to add another peripheral to the mix.

That’s understandable – I’ll follow up now on your ticket.