IR remote with Pi DAC+ configuration

Hi,

If I’m honest I think I’m trying to run before I walk but I think I’m missing something so I’ll explain as much as I can.
As you can tell I’m very new to the pi3. And intend on using it as a audio source and media player.

I’ve downloaded the pre configured OSMC image from IQaudios website just before Christmas (I tried myself to configure but couldn’t get it too work) and the DAC works for audio only to listen to music and when viewing a film, can be used with the tv only with a work round i found on here by using different players to separate there usages.

Luckily my Sony TV has a bravia sync feature which when the pi is connected on the HDMI, the TV remote can control it however, I want to be able to move the pi to different TVs around the house.

I’ve soldered an IR tsop4838 on the pi DAC+ and from Gordon’s helpful PDF this uses GPIO 25 as an input but I can’t alter this in the settings as it only goes up to 24.

I’ve learned how to SSH into the pi (basic) but lack the experience obviously! Im assuming I need to learn the remote I’m using as its not listed (which is an old sky+ remote but that’s not set in stone) with irrecord but because the input isn’t right, it won’t see the remote I’m using! Do I need another Linux distro to alter the config file or can this be done within OSMC?

Any help pointing me in the right direction would be great. I’m just sorta stuck in a loop search the net for answers and not getting anywhere due to the lack of experience with the Linux OS.

I’m on the latest software and up to date.

Cheers

You can edit /boot/config.txt or configure in My OSMC.

I think that some DACs use GPIO18 which is what the LIRC GPIO receiver overlay uses by default.

So set it to 24, look at /boot/config.txt, and edit the line accordingly.

Maybe this is something we need to adjust in a future update. Let me know when you get it working first.

Edit /boot/config.txt to pin 25 , you’ll need to use “sudo” to edit it
Check here for your remote (you may get lucky) http://lirc.sourceforge.net/remotes/

Just a word of caution. The RPi’s GPIO layout can easily be cause of confusion since the pin #25 on the board does not equal GPIO25!

See here for details on the pin layout:
Raspberry Pi GPIO Pinout

I hope you didn’t solder the IR receiver to pin #25 as that’s a ground pin.

Yep – there’s the actual pin numbers and then there’s Broadcom pin numbering.

Thanks everyone for your replies!

I’ll have a proper look at these over the weekend but to answer if I’ve got the right pins. I followed the PDF as shown and I’m sure I’ve soldered the receiver to the right part, but I’ll double check :slight_smile:

I’ll report back how I get on :slight_smile:

So far ive edited the config.txt file to GPIO input 25 and have made progress with irrecord to get a config file made up and something its actually reading! This is alot further than i thought id get with so little knowledge.

however, this has happened before and i cant remember what i did to correct it last time.

I can see the config file ive made up in the my osmc/remotes list but cant select the file from the menu. it seems to be stuck on RC6 (when i hover over the disable)

like something is broken… maybe when i stopped the lirc service?

Edit= to get this back i,
sudo apt-get install lirc ( which removed all the remotes and then)
sudo apt-get -f install (which i think forced to be reinstalled. this seems to have got the frontend working again)

some of the key names are wrong for the config file so i need to see if i can edit the file i created… ie i thought KEY_SELECT would be light right clicking on the menu but doesnt appear to do anything.

thanks for all your help so far folks :slight_smile:

OK. After spending all weekend glue to the front of it and going round in circles, I succumed to someone elses interlect and bought a cheap Xbox 360 media remote which came today and works a treat from the lirc config files DBMandrake uploaded. Thank you

This has only happened a few times since rebooting and inputting the license codes I got from the raspberry pi foundation website, but the above mentioned GPIO 25 which I need to use the remote through the PI DAC+, I changed in the config.txt a few days ago, this keeps refering back to the frontend maximum slide bar of 24 in the my osmc/pi config/hardware support. Ive tried a few ways to change this but it always refers back to 24. Is there any way of making this stick???

If it works, ignore it.

@Karnage Can you commit a fix to allow > 25? Is this appropriate?

I’ve not had a lot of time to fully test it out so I’ll reserve 100% commitment just for now, but the limited time I have had, the remote worked on some after a reboot and didnt until requiring re-confirming the remote config and editing the GPIO input to 25 again in config.txt.

If it persists I’ll post up again…

Again thank you for your help :slight_smile:

I’ll email Gordon about this now. As the 4838 isn’t actually installed on the board, this hasn’t really come up before. Better to get it all working in OSMC so our update system can take care of things.

Sam

Thanks Sam, I think a few folks plumb for the USB flirc ir adapters and also use the rii wireless keyboards which I bought both of, not understanding properly what I really wanted them for. The flirc went back as I wanted to explorer for further projects and was a lot cheaper (50p) for an ir receiver then 19.99 for the use adapter, I’m undecided on the rii mini 8 whether to keep or sell…

After a complete power down and off it looses the remote. Re-enabling the remote settings doesnt do anything. Only editing the GPIO input pin to 25 from the 24 and a reboot solves it, until the next power down and off where again it looses the remote and the config file has changed back to 24. This is repeatable too. :disappointed:

If that’s the case, I can’t believe this hasn’t been documented before now!

Yes, looks like we need to add support for a higher pin-range. This will be included in a near future update, when Kodi Krypton arrives.

But the remote will only stop working if you re-open My OSMC → Pi Config until you receive the update. If you leave it alone, the config.txt will not be changed.

Let me know if you still have any problems after the February update

Thank you :+1:

That’s awesome