Is April update incompatible with shared MySQL Server?

I’ve been running my three Ras Pi 3 OSMC systems with a common MySQL database for nearly 6 months. I just installed the newest update this morning, and have met a black screen. I tried to muddle through the upgrade on the first without paying a lot of attention to the log, but captured log info from first boot on the second.

First post-update boot log (from second Pi upgraded):
… DEBUG: Initialize, updating databases…
… NOTICE: Running database version Addons27
… NOTICE: Running database version ViewModes6
… NOTICE: Running database version Textures13
… NOTICE: MYSQL: Connected to version 10.1.37-MariaDB-0+deb9u1
… NOTICE: Running database version MyMusic72
… ERROR: SQL: [MyVideos116] The table does not exist
Query: SELECT idVersion FROM version

The first RasPi I tried to upgrade didn’t have logging enabled, so I made a couple of checks to verify that the credentials for the remote MySQL server is root (as Kodi tries to migrate the database) and that logging was enabled before I pulled the trigger on the upgrade on the second Pi. And I verified that remote login by root is enabled on the remote server.

While working with my first RasPi, it couldn’t find the MyVideos116 database (which didn’t exist yet becaues it didn’t try to create it) so I did that myself on the remote server and verified that root had full permissions on that database.


<?xml version="1.0" encoding="utf-8" ?> MyVideos ****** root ***** mysql 3306 false false 2

Root is god on the MySQL host machine. The server is running, and I have full control remotely logged in as root.

It seems incapable of creating the database, and doesn’t seem to even try to create any of the tables. Can I/should I try to create the entire database schema on the remote server? Is there an SQL script which will do this or, would I have to build the script from the schema descriptions?

If I navigate to My OSMC >> Network >> MySQL, it permits me to check the boxes to enable remote MySQL for MyVideos and MyMusic, but doesn’t offer the fields to provide host/user/password/port, etc.

I am familiar enough with advancedsettings.xml that I could set up the connection without the GUI (at least per the standards prior to this update), but thanks to the aforementioned MySQL issues, am unsure if this update actually fully implemented MySQL before it was released.

If I remove the MySQL settings in advancedsettings.xml (over SSH since I get nothing but an unresponsive black screen), I can repopulate my catalog without using MySQL, but I really prefer the single-point update, and the ability to view/update the data with tools other than SQLite over SSH or the GUI!

Can you show your user table, maybe something is wrong there.
Also show a screenshot of all your kodi tables (names)

Did you wait for the database to be migrated after you updated the first system? The migration can take a while (10 minutes or more depending on the size of your database.)

If you interrupted the migration that may cause the error you are seeing. The easy fix would be.

  1. Shut down all V18 versions of Kodi that are running.
  2. Remove MyVideos116 from the server
  3. Start 1 (and only 1) version of Kodi and wait for the database migration to complete.

Kodi will also need to be able to create new databases; so make sure the user accessing the database has permission to do so.