Is it a simple fix to revert to v18?

Followed the upgrade path a few days back, found myself in the frown face reboot loop. Grabbed a keyboard and broke out of the loop, updated via command line and all seemed fine.

However, watching a particular 1080 show, it seemed that whenever there was a fade to black moment in the edit, the screen would then switch completely black (no backlight) and not come back until I’d pressed stop. Audio carried on fine. Like it had gone to HDR black or something and not come back. Laugh away geeks, I don’t understand the terminology.

Decided to rebuild the Vero completely from a usb to a clean v19 build (never had to do this before, didn’t realise it was a different process from my RPis) and it seemed to be working perfectly from that point.

That is until the next day another update was performed and the problem returned.

Is it a simple case of downloading the v18 image and putting that on the Vero and disabling updates? I know this is a dirty fix, but I’m too busy right now to spend time on this.


Yes, that would be the quick and dirty solution. But it will be not very likely that then your problem is solved in the future.

With limited time available, what would be required to initiate some problem solving?

8K certified cables, Marantz 6012 amp handling the passthrough. Everything is vanilla in OSMC apart from enabling audio compatibilities in the system settings of OSMC.

I’m going to try the same files on an RPi3 later just to see if it happens there too.

Enable debug logging replicate the issue and upload logs.
As it is only certain files provide mediainfo of that files.

You should probably check what happens if you bypass the Marantz and connect directly to the display, too.

Unfortunately that’s the kind of thing I don’t have time for. Taking media units apart and rerouting cables.

I’ll try the debug route and if I get time later I’ll try it on the same version of Kodi but on an RPi3.

If you install latest OSMC version on the Pi3 you would have identical Kodi versions.
But I guess debug logs and mediainfo might already give us an idea

Hi, I jump on this thread because I experienced a similar behavior since the last update to Kodi v. 19.1 and the latest OSMC.

The update went all well using the update function on “my OSMC”, no sad face or so, data migration went fine as well.

Watching movies, mostly 1080p.mkv and UHD.mkv, and TV shows showed sometime an error described by the TE:

The screen turns black, but sound is still running. The vero 4K+ seem not to respond to remote command via CEC for a long time, then stops the movie. Pressing “play” continues to play the movie with picture and sound as normal.

I have tried several times to log this behavior, but when I tried, the movie or TV show played fine. For 3,5 hrs. the device played fine, another day the described error occurred after about 1,5 hrs. Going back to the timestamp in the movie where the screen went black showed no error the next time I tested. So, the file itself should be OK.

Because of this error I reinstalled the November version of OSMC with Kodi 18.9.

Is there a possibility to do logging without this permanent message on top of the screen? I would happy to provide logs but since the problem occurs only seldom in my case, the logging message disturbs the enjoyment watching movies.

Yes, add <loglevel>1</loglevel> to the <advancedsettings> section of .kodi/userdata/advancedsettings.xml

1 Like

You don’t, by chance, have your GUI set to 4k without Adjust refreshrate turned on? That’s a known problem setup.

Unfortunately not, it’s 1080p interface. I did have it at 4K in the previous version, but it is definitely set to 1080P since the reinstall.

You mention a Marantz AVR. I had quite a few issues with an NR1711, did not want to pay nicely with the Vero. Eventually a Marantz firmware update seemed to sort issues I was having with 1080/50 4:4:4 blank-screening me, but before applying the firmware update, a couple of things helped, that no longer seem to be needed:

  1. User the Vero’s force 422 option

  2. My AVR has an 8K enhanced mode. Enabling that enabled 4:4:4 compatibility on all the inputs at 50/60 Hz (now fixed in default mode by the firmware update, was a Marantz bug).

It’s played nicely for a couple of years now, so I assume this bug isn’t apparent on this model, or a previous firmware had already fixed any issue like this. It’s only happened since the v19 upgrade unfortunately.

Can I replicate the problem that could be replicated over and over yesterday? Nope.

I can’t help but feel like visible logging actually stops the problem from appearing, the constant white text in the corner stops the issue of the screen going blank because it’s received a “go blank” signal because the screen isn’t blank.

Thank you @fzinken for your hint. I will log when I reinstall the 19.1 update what might take a while.

While I am back to the November edition of OSMC and Kodi 18.9, I found that I have similar errors as reported above with some TV shows. But with Kodi 18.9 the picture only freezes for a couple of seconds and the sound continues (with Kodi 19.1 the screen turns black and the sound continues).

It may be that that the error handling of stream errors has changed from Kodi 18.9 to 19.1 and that errors seem to be handled more rigid in the last Kodi version. Unfortunately, I have no knowledge regarding the changes inside the Kodi versions.

I know that I had picture freezes (and sound still running) for a couple of seconds until the played stream was paying sync again with OSMC and Kodi 18.9 in the past. Honestly this picture freezes were short enough so that they were not annoying. But with a dark screen under Kodi 19.1 the situation is far more irritating.