Is it possible that not all Apple Remotes work with OSMC?

#1

I recently installed OSMC on an AppleTV.

I could not find my trusty aluminum remote so I unwrapped a NEW white remote (I have a box of em I bought cheap). None have ever failed out of the box yet, however this one did not control the AppleTV other than Pair, unpair , & reboot. Other remotes DO work on the new install.

As I recall these remotes have a unique ID that goes in the IR to ATV.

So this leaves me wondering if I isolated a remote whose unique ID is not recognized by ATV client.

I will see if I can look into getting ATVclient in the test mode to see what I can see.

Of course I could have just got a dead remote, but as it was brand new it seems unlikely, and also the pair unpair and reboot functions do work

#2

I had to unpair my remote and it worked great after that, when id pair it back it would function really weird and the buttons where all messed up, try to unpair it and see if that fixes the issue? Do not pair it again just unpair it and see…

#3

I tested paired and unpaired

#4

I had the same problem as many people here on the forum: I could pair and unpair the original Apple remote with the Apple TV, and I could send it to sleep. But the buttons wouldn’t work.

Apparently the problem lies with atvclient. It runs as a service and controls the input from the IR port. A small change in its configuration made all the difference.

Here’s how I made the aluminum Apple TV remote work with OSMC on an Apple TV 1st Gen:

  1. sudo nano /lib/systemd/system/atvclient.service in order to change the config file for the service.

    Change ExecStart = /usr/sbin/atvclient -m to ExecStart = /usr/sbin/atvclient -i 3 -b 2

    This makes the service listen not to many, but to just one remote. The options b and i change the LED to make it behave more like in the original OS.

  2. sudo systemctl daemon-reload to make the system aware of the changes.

  3. sudo systemctl restart atvclient and you’re good to go.

You can test atvclient by running /usr/sbin/atvclient -h from the command line. Experiment with the options and then modify the config file to your heart’s content.