Is it possible to set write permissions in autofs or fstab?

Hello world,

I am running into a problem whereby, I think, my Synology 218+ keeps resetting/losing the write permission on my NFS mount. I tried Fstab and Autofs and both work fine for playing files but when I need to write to the mounted folders, and I really only do this for downloading subtitles, it will work for a few days but then will lose the write permission. When I reset the permissions on my Synology everything will be fine again for a few days but the the whole thing will repeat itself.

I read somewhere that Synology is a little bit shaky on the NFS side and it could have to do with the Squash settings. I have it set to: All users set to Admin and Synology would reset these squash settings automatically after a few days, but I am not sure if that’s true.

I am really not a computer wizz so I would like to know if it’s possible to set additional read and write permissions in autofs or fstab?

I used this how-to, to mount my NFS Shares on my Vero 4k plus and my Raspberry Pi

and previously used Fstab via this guide:

if someone could help me out it would be much appreciated

Sounds like something is running on the Synology that is resetting the file permissions. There isn’t really anything you can do from a mount if the NAS is changing permissions on the filesystem. Can you SSH into the NAS to verify the actual permissions and owner of the files?

I get this:

How I set it up, here


/etc/fstab: /mnt/music nfs defaults,x-systemd.automount,noauto 0 0

root@osmc-vero4k:/mnt/music# ls -al ..
total 60
drwxrwxrwx 12 root   root        4096 Jan  1  2015 .
drwxr-xr-x 23 root   root        4096 Jan  1  2015 ..
drwxrwxrwx  5 nobody 4294967294 12288 Jan 28 20:46 music
root@osmc-vero4k:/mnt/music# ls -al
total 396
drwxrwxrwx   5 nobody 4294967294  12288 Jan 28 20:46 .
drwxrwxrwx  12 root   root         4096 Jan  1  2015 ..
drwxrwxrwx  30 nobody 4294967294   4096 Jan 25 14:35 Klassische Musik
drwxrwxrwx 217 nobody 4294967294  12288 Jan 24 16:09 Musik

you’ve to restart the Syno to make changes to NFS active

Thank you I will try again and use your settings but it seems that my Synology is resetting the read and write permission as shown here:

where almost everything is unchecked while a few days ago I checked the following boxes:

and saved. I did not restart the Synology however so I will try that.

Wow I never checked these options. Thank you! Let’s see if this works.

Ok I get it al working after checking the right boxes in Shared folder/Permissions as well as in File Station/properties/permissions.Only when I restart the Synology all of the settings are gone/boxes unchecked and therefore lose all writing permissions. I can still access the shares though.

Before restart Synology:

After restart Synology:

I think this is a Synology problem and I should start a ticket with them to get this solved.

Ok, let us know what the problem was with your Syno, then.

I finally found the cause why my nsf folders kept losing the set permissions. I am running two docker containers on my Synology that are causing the problem. It’s the Haugene/Transmission-openvpn docker container which downloads torrents to my nfs shared folders and somehow resets all of the permissions, not only on the folder side but also the user permissions on my Synology. I changed the destination folder in the docker containers and the problem is solved.

So you were right al along :grin: