Is there any news on the ability to use external hdd to boot RPi2?

Hi all,

Can anyone tell me if it is possible to use a USB HDD as the root file system yet?

I had Raspbian running sweetly booting from the SD with / on the HDD but could not get KODI to work! Now I have OSMC with KODI but no / on HDD!


This has been available since OSMC’s inception.

Simply select USB install when installing OSMC via the installer.

I have tried that 3 times in the last couple of hours and OSMC says ‘failed to initiate device’.


A bit more information please, describe the steps you’re taking, the hardware you’re using and how it is connected.

USB installs have worked from day one so we need to know what is peculiar about your partition installation.

Thanks for the reply, here are a few details…

i am using OSMC Installer on Debian 8.0 to write the 20015-11-01 image to the SD card with ‘install to USB stick’ selected and my wifi details set. The write to the SD card goes smoothly.

On the RPi2 I am using samsung M3 1TB portable HD, a bluetooth keyboard and an MT601n usb wifi dongle. I have a good power supply and have no issues with under powering.

After the warning about the device being formatted I get the message ‘install failed: can’t mount root’. The RPi2 just hangs then.

Is there an issue with the partitions on my M3 HD as I have 4 ext4 partitions and 1 ntfs partition.
Does OSMC expect a fat32 volume on the device?


You do realise that OSMC will completely wipe and repartition the external drive that is connected on first boot ?

It’s possible this is failing due to a bug due to all the partitions that are already on the drive, but if the install process was working properly your drive would be reformatted to a single ext4 partition for the root file system.

If there is no data that needs saving on the drive your best bet may be to delete all the partitions then try again.

Another thing to consider is if you are powering the drive directly from the Pi, you might need to manually add max_usb_current=1 to the config.txt on the SD card after running the Debian installer but before booting in the Pi the first time, or there may be insufficient current to power the drive.

Then after the install completes and reboots you would need to manually add it to the new config.txt as well. (The install image and the final install have different config.txt files)

Ok I have used the max_current setting and the install is progressing. Woohoo!

I had tried the same set up with the hd plugged into my powered RasPi hub and it failed there too but it is going now.

I will post an update later to confirm everything works.

Many thanks for the tip and for your efforts for the community,


OSMC installed fine. I have resized the root partition and added some more.

I wondered if it is possible to have a GPT disk label option and also if the cmdline.txt allows for root=PARTUUID=xxxxxxxxxx-xxxxx boot device labels as USB devices can be ordered differently on booting.

For the time being I will continue my set up and enjoy using OSMC as my media centre.

Thanks again,


PARTUUID was deprecated when we introduced initramfs proper.

use ROOT=UUID (blkid UUID labelling) now.


What is the exact format for UUID of ABCDEF-12345 in cmdline.txt?
Is it…

Thanks in advance,