Is this USB wifi dongle supported?

I am considering downloading OSMC for my raspberry pi but I am hoping to find out if this wifi dongle is supported?

TP-LINK Archer T2UH AC600

If so, does it work straight out of the box? Or do I have to do anything to get it up and running?

If you have the dongle, plug it in and try it.

If it’s not supported, give us output of dmesg and we’ll add support for it. It should be supported


I tried it last night and it didn’t work. I’ll get the output tonight and hope it can be supported :smile:

Is this the information you want?

Hi there

This is my first post here and wanted to add tot his thread. Today i have installed OSMC (love the GUI) and im also looking to use a TP-LINK AC600 USB Wifi adapater but im not getting anything.

Heres my dmesg, hope it helps. I would really love it if you could include this in a future release otherwise I might have to drill holes in the house to run Cat6 and I don’t think the wife would be too happy with me :smile:

Let me know if you need anymore information.



Still no support for the AC600?

+1000 for support for the Tp-link archer ac600

Guys, judging on OSMC I believe SAM is a great programmer but he is not a magician, So please don’t expect him to support a wifi stick that doesn’t have Linux support.

haha! no i’m not expecting magic at all, im just saying it would be very nice :slight_smile:

And it looks doable, however this is for another architecture so it won’t work out very well ^^
compiling it for Ubuntu

Hi, I´m also trying to get this adapter working on my RPi, I can see there is a linux driver for this on the web site (official T2U support page), I’m sure it’s not an easy job but it would be awesome you can achieve it.

I’m glad I discovered this this distribution, It looks awesome, I had some restarting troubles during first time configuration, but now it’s scanning files (with another compatible wifi adapter) and is going fine. I hope this distro can finish with the constantly restarting/freezing problems during video streaming from NAS (WD My Cloud)

Add another +1 to this list. Stupidly didn’t think about checking before buying the TP-Link Archer T2U wifi dongle. seems like it is still not supported.

Any updates on if compatibility will come or is it worth returning it?

When you request support for a new WIFI device this information is required:


Product name: TredNet TEW-649UB
Chipset: RTL8191SU
Product ID: 0x8172
Vendor ID: 0x0bda
To get this information listed easily please install 'usbutils':

sudo apt-get install usbutils

Afterwards run:

lsusb -vvv

You will get a long list with information about USB stuff in you system. 
Somewhere on that list you will find with the WIFI network adapter listed as below, with the idVendor (Vendor ID) and idProduct (Product ID), which also mostly tells you the chip used, in this case RTL8191SU:

Bus 001 Device 004: ID 0bda:8172 Realtek Semiconductor Corp. RTL8191SU 802.11n WLAN Adapter
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.00
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x0bda Realtek Semiconductor Corp.
idProduct 0x8172 RTL8191SU 802.11n WLAN Adapter

Good luck in your quest to find the needed information, and we will look forward to supporting as many adapters as we can over time.

Is this correct?

Bus 001 Device 004: ID 148f:761a Ralink Technology, Corp.
Couldn’t open device, some information will be missing
Device Descriptor:
bLength 18
bDescriptorType 1
bcdUSB 2.01
bDeviceClass 0 (Defined at Interface level)
bDeviceSubClass 0
bDeviceProtocol 0
bMaxPacketSize0 64
idVendor 0x148f Ralink Technology, Corp.
idProduct 0x761a