Issue regarding smb share

Hello. After updating to the latest OSMC update,i have a lot of hiccups,and pauses while streaming music from my NAS.Before that ,everything worked great. I have updated advanced settings for use with kodi v17 but nothing changed. Can you please help me?

Raspberry Pi 2B
wireless adapter : osmc wifi dongle5 ghz
NAS : OpenMediaVault

Thank you in advance

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload some logs. You can learn more about how to submit a useful support request here.

Thanks for your understanding. We hope that we can help you get up and running again shortly.

Thank you for your response.

  • While i am locally streaming music from my NAS to osmc ,i am experiencing a lot of pauses.

  • This only happens on music and not on movies

  • When i straming music i am experiencing a lot of pauses. This happens very often ,and only while i am streaming music.

  • Raspberry Pi 2 Model B

  • OSMC 5ghz wifi dongle

  • It started after the first upgrade to kodi 17. Before that ,everything worked smoothly

and here is the full log →

in the log this issue occured again while a Faithless song was playing.

Thank you very much for your time.

This is my current advancedsettings.xml file…:


Is this correct?

Don’t user 0 for memorysize, shouldn’t be necessary. Use the default of 20mb (20971520).

Yes but how this is going to help the issue I am facing? If I understand correctly this option uses the whole SD space for buffering which is fine by me.

Ok, I just noticed that your log indicates that you’ve already placed these settings. Still you have stutters. If you test with ethernet instead of wifi is the problem resolved?

No it is still the same . This started after upgrading to kodi 17. Before that everything worked great

You haven’t enabled debug logging as directed in the link provided above so, the Kodi logs contain nothing helpful.

there you go

Don’t use a hostname in your smb source. Try using the IP of the source.

Small update ont this. I tried to use nfs protocol ,instead of smb but still no luck .The stuttering continues

i also tried fresh installing OSMC and i can confirm that the stuttering is still present .

Try playing a problematic file that you have copied onto the pi. Also try playing a file over ethernet, not wifi.

+1 with this issue.

I had the same problem with 24-bit/96kHz FLAC files (standard definition 16-bit/44kHz worked fine though). Kodi v16 handled them all flawlessly, and now stuttering with v17. No wi-fi, no change to NAS structure. The only change here is rolling from v16 to v17.

So between that (I play a lot of music off my NAS at home), and v17’s inability to wake up a Pi 3 from a CEC compatible remote, I dumped v17, rolled my Pi back to v16, shut off automatic updates, and I’m happy as a clam. Unsupported? Yes, but happy.

Thanks for your reply.

So either staying with this stuttering or downgrading to kodi 16? :frowning:

Anyone else with this problem?

Yes, I have a similar problem. In my case I experience a delay of about 75 seconds before switching to the next song in certain cases. I subsequently found out that this only happens when the currently playing song is longer than 5 minutes. Used to work perfectly with kodi 16 and Confluence skin. Once the music starts playing, it is smooth. Starting a new music Playlist, also have this delay. My music library is on a SMB share in Windows 10.

UPDATE: After updating my modified Estuary skin, the problem was resolved!!