Issue to connecto to SMB 1 (legacy) devices after July update

I had the sad face loop at the weekend, I hadn’t updated for 2 years (oops) and it got stuck on 68% first time around using My OSMC. Long story short I have started fresh after erasing and reformatting the SD card but 2 problems exist.

  1. I cannot add my Seagate Central network drive as an SMB share (using IP). It immediately says connection timeout but it works fine on my PC running an older version of Kodi and my other RPI2 running an old version of OSMC. (This one is an RPI1 B+)

  2. I can access the media going via upnp but when adding a source it does not allow me to select the type of content and scanning to the library does not work.

I have spent hours trying to sort this out, do you think the SD card is the issue or has something changed with updated versions of Kodi? Next I will add some media to the SD card and see if that helps.

This is most likely caused by the fact that your Seagate can only support the insecure SMB1 protocol that has been blocked in the last update. You could try to edit .smb/smb.conf see this thread

I see. Could anyone elaborate on how I modify that file, I know just about enough to get by and I am living in Australia so I will be trying it tomorrow when most people are asleep.


nano ~/.smb/smb.conf


client min protocol = SMB2


client min protocol = SMB1

ctrl-x to exit and yes to save changes.

I believe that should do it.

Thanks Tom.

You may (not sure) need to run sudo systemctl restart mediacenter afterwards


I knew I forgot a step, I may be wrong a full reboot may actually be required to pick up the new smb client configuration.

Thanks Tom.

I think restart should be good enough as it just which Parameter Kodi uses with the library. But I guess we will see.

Thanks guys, worked a treat and it solved issue 2 at the same time. Only sudo systemctl restart mediacenter was required afterwards.

Is there a security issue with using the Seagate as my media source? I have changed default passwords on both RPi but is there anything else I should be doing?

As long as you are not forwarding ports to the internet, and have your wifi protected, there should be no issue with using the Seagate.

Everything is default since fresh install yesterday. I use Yatse but only when connected on Wifi in the advanced settings.


Glad to hear its working and good to know only a restart of kodi is required.

Thanks Tom.