Fix for "Connection Timed Out" accessing SMB

I just got a Raspberry Pi 3 and installed OSMC. I’ve been using an RPi2 with OSMC for a couple of years, and this new one will be going on a different TV. I was unable to access any SMB shares with this new box though, despite trying various fixes on the forums. I was able to resolve the issue by modifying the .smb/smb.conf file. The line in question was

client min protocol = SMB2

I changed it to read

client min protocol = SMB1

Evidently at some point SMB2 became the default protocol level for OSMC which is incompatible with the SMB server I have running. If you have the choice of running SMB2 you should, as SMB1 is unsafe, but if you don’t have that option and are unable to connect to your SMB shares, try changing that setting.

1 Like

This security fix was introduced with the July 2017 Update of OSMC.

Well that would definitely explain it. I haven’t updated my other unit to 7/17 yet. Thanks for the info. When I update will it overwrite my existing settings with the new ones you mentioned or will is this only for new installs?

Once smb.conf is created, it won’t be modified by Kodi, so your changes will
be persistent

So how do I configure SMB2 with OSMC so it works with Android and Windows?

Something like this?

Your question is a bit confusing and also this is a kind of thread jacking as this is about SMB1 fix.
So suggest you are first clarifying are you talking about accessing OSMC Samba server from Android/Windows?

What? Thread jacking? It was clearly stated in the earlier in this thread that smb was upgraded from smb1 to smb2 in OSMC, and that was causing most access issues. What I am asking, is whether there needs to be a different way to configure smb.conf for the newer version.

This thread is about OSMC as SMB client, is that the purpose of your question?

Thanks for the fix that solved my problem after months of trying! :slight_smile: