Issue with audio passthrough on Vero 4k


Have just received my Vero 4K and am very impressed so far. I’ve had one issue - passthrough of Audio to my Sonos, I’ve enabled passthrough on the Vero and just enabled ac3 capable receiver as this is all the Sonos is capable of. My LG TV supports DD passthrough and these settings have worked flawlessly with Kodi on the firetv and my Intel NUC but with the Vero I only ever get a Stereo audio stream when it would usually transcode to DD 5.1. Are there any settings that I’m missing?

You need to enable AC3 transcoding if you want non AC3 sources to also be sent as AC3.

Hi Sam - thanks, the stream I’ve been testing with is a DTS stream, so would expect that to be transcoded to 5.1 DD. Sorry should have added that in the original post

Please show a photo of your audio settings.

I’ve tried setting no. of channels to 2.0 and enabled transcode also

  • Should be set to HDMI, not PCM (assuming you are using HDMI connection to Sonos)

If still no joy, post a debug log via My OSMC.


Will give that a go and post the debug log if required, thanks