Issue with remote control maybe?

Ian and I have two Veros - a 4K and a 4K+. The 4K - which is probably quite elderly now - has been running mostly fine but yesterday it stopped responding to its remote control. I checked its battery with a megger thing and it seems ok - 3V?-but it doesn’t have any effect on the menu screen. I switched the remote sensor from the 4K+ but still no movements. The menu screen pops up OK on boot and the clock advances. Is there any way of checking if the problem lies with the remote or the 4K unit?
PS: Sorry I forgot how to send a pic of the boot\menu screen,duh.
Thanks, Cleo

Did you paired the remote afterwards? Or did you try the 4k+ remote?

You could try to control the Vero via CEC (your TV Remote) or if you have activated Web access you could try it from your browser.

Did you paired the remote afterwards? Pair the remote? What? We don’t know what you mean. All we’ve ever done from the beginning is unpack each Vero (4K and 4K+) and turn it on with its own remote and gone on from there. Each remote only works with the Vero it was packed with. When I said,“'I switched the remote sensor from the 4K+ but still no movements,” what I meant was that I swapped the remote control’s sensor gizmo in case it was just the sensor that was faulty. As I said, the remote controls have only ever worked with the Vero that they came with.

I don’t understand your next comment, sorry. (You could try to control the Vero via CEC (your TV Remote) or if you have activated Web access you could try it from your browser.)

It seems to us simple folk that the 4K remote has died. How do we get another remote that will work with the older Vero 4K?

Hi Cleo,

We will get this solved for you, don’t worry.

Every remote is paired to the remote receiver, otherwise you’d have chaos if you had more than one device in your home (which you do)

Sometimes remotes and receivers can fall out of sync, particularly if they’ve not been used for time. This is a power saving measure. If you’ve not used it for a few months, why bother using battery to phone home.

To re-pair a remote:

  • Remove the USB from Vero 4K
  • Hold Home and OK button for 5 seconds or so, then the blue LED will keep flashing.
  • Plug in the USB receiver and the LED should flash 3 times after 5 seconds, indicating successful pairing.
  • Power off Vero 4K for 2 minutes. Turn it back on. The remote should now work.

But if the dongle is defective, it won’t. The LED will hold a steady blue. But it will also do this is if the dongle you are using is incompatible.

We’ve also updated our remotes a few times with new features between the Vero 4K and 4K + series so there is not guaranteed compatibility between these two remotes.

In short: my suggestion is to try the re-pairing process first with the original receiver for each remote and see how it goes.

I hope this clarifies things



There are many more options to control your Vero than just using the Vero remote.

  1. A very popular option is CEC (Consumer Electronics Control). A technology that most modern TVs (since 2005) support. Many of them call in different like Anynet, SimpLink,… Fundamentally CEC allows you to control your Vero with your TV Remote. Just when you have switched the TV picture to the Vero try the arrow keys on your TV remote and see what happens.

  2. You can also remotely control your Vero Via a Webpage. This allows you to e.g. Use a remote application on your phone to control the Vero. As a simple start you just type the IP address of your Vero into the Browser on your PC or Phone and you should see a webpage coming up. But this option need to be enabled (Settings - Services - Control - Allow Remote control via HTTP). But surely if you haven’t enabled it before it would not help you now.

Thanks Sam. That sounds like something I can try. Ian’s 84 now, so best if I do the pairing thing. Just a point, though. We’ve been using the 4K pretty much non-stop since Ian bought it back when. This is mainly because the display colors look better with that device than with the newer 4K+. Kind of hard to describe but we both prefer the 4K picture. So the 4K hasn’t been sitting unused. While the 4K+ always works even though we rarely use it. Which we’re doing now, of course.
Anyway, I’ll try the pairing thing and see what happens.
fzinken: Thanks for the clarification. Our TCL TV is fairly elderly, too, but I’ll try your suggestion.

They should look exactly the same. The only thing I can think of is that they are running different versions of OSMC or you’ve got them in different HDMI ports which might have different settings on your TV.

When remote connectivity is restored on both, we can check the version each device is running and advise accordingly depending on which one looks bette for Ian



Yes, that’s what we thought, but the colors definitely behave differently. But I’ll just try the pairing etc before anything more complicated.
And yes, the two Veros are on different HDMI ports in the TV.
Thanks again, we really appreciate your help. :heart_eyes:

I think it will be the HDMI ports. In older TVs some ports don’t support full colour.

Once we have you able to control both devices, we can check logs to make sure OS version and settings are the same to rule out an OSMC issue



Hi Sam. I just tried your instructions and nothing happened. Like, the blue light (which I assume you mean the blue light on the front of the 4K case) didn’t flash at ANY time.
BTW, I assumed you meant remove the dongle when you said ‘Remove the USB from Vero 4K.’
I repeated the process several times but the only change in the light status was when it changed from its initial red to blue, which then stays on.
I haven’t tried re-pairing the 4K+ because its light doesn’t remain on after your re-design of that function, so I’m not sure how the re-pairing works on that unit.
And BTW, the TV remote up\down arrows don’t have any effect on the 4K screen menu.
Thanks, Cleo.

I refer to the blue light on the remote, not the device.

The TV may be too old to support CEC which is the mechanism that would allow you to control the Vero by TV remote.


Oh, ok, I’ll try again :face_with_hand_over_mouth:

So far, no progress. As I said, the remote’s battery seemed to test ok, with 3V showing on the megger. But I’ll get some new batteries and try again. Off to a night shift now, I’ll come back again tomorrow with batteries and try again.

Hi Sam. Well, I don’t know what I did but the 4k has a working menu again. First, I had a close look at the 4K+ remote to make sure I knew what the ‘blue light’ that you referred to looked like, because I wasn’t aware that there was a visual confirmation of remote control key presses.
So that was there, but not on the 4K remote. Then I tried a new CR2032 battery in the 4K remote but that had no effect. Then I did your recommended pairing sequence - several times - but still no response. I tried switching dongles and remote sensors but no joy. I cleaned the contacts on the 4K battery compartment - again - and checked that they looked normal. Still no response. Finally I put everything back the way it was - even replaced the old battery, switched it on (without pairing) and it worked!
So all is now OK but I have no idea what the problem was. Whew.
You mentioned ‘checking the logs’ on both devices. How to do that?

If it works now, logs won’t be needed. Logs were to check if the receiver was being detected on the device.

I’m not accusing anyone but if that remote has been dropped a lot over the years, it’s possible the battery contacts came a bit loose and you’ve pushed it back in slightly and now it works again.

Don’t mess with it if it isn’t broken, but if you have a problem again, you could show us a photo of the battery compartment of the problematic remote here. I would like to ascertain what happened to improve the robustness of the remote for future customers. Reports of issues are low, but there’s always room for improvement.

There should be a blue light (very quick flicker) when you press a key on a remote when it is operating normally.

Glad it’s working now. If you have any problems let me know. I am not charging an 84 year old man for a new remote if needed. Good health to him and you.

Thanks, Sam, you’re the best. And we love our Veros and how they work with our networked TV and computer system.
In the same way that we bought the 4K+ as a backup of the 4K if it failed, we’re wondering if we should look at getting a Vero V. What do you think?
By the way, some of the movies we download (2160) show up on the computer (where we download them first to check for quality and subtitles) as very grey, or even purple and green. They come through on the Vero\TV with the same colors. Apparently it’s because they’re ‘Dolby-ised’. So we just grab 1080 ones instead.
But could we play Dolby shows? What would we need to do?
Much thanks :heart_eyes:

Hi Cleo,

It may make sense for you to upgrade to the Vero V. We will discontinue software support for Vero 4K and 4K + at the end of the Summer.

Subtitles may show as grey for some HDR material on Vero 4K / 4K + because the user interface and video share the same plane (technical limitation). On Vero V, we have a dedicated plane for the UI and one for the video, so subtitles can be rendered independent of the video and are more legible, particularly in some dark scenes.

Yes, the green and purple colours are the result of playing files that are encoded in Dolby Vision Profile 5. These do not have an HDR fallback layer. The Vero V is able to play these files and output them as HDR so they look correct. You wouldn’t need to do anything for this to work – just make sure you are on the latest software when you receive your device for the best results.

I hope this helps

Many thanks