Issue with xbox controller

I’ve been trying to get the wireless xbox controller to work the RPi, and I’ve walked into some problems. First and foremost, I’ve tried the adapter on my desktop computer, both running Arch Linux and W10, and it works fine. However, on my RPi I have random disconnects, with the error 12/32(Transfer/write error). The RPi is powered by a 5V/2.5A power supply(the recommended one) so I figured that wouldn’t be an issue; perhaps the USB port cannot reliably power a receiver? I compiled xboxdrv from source, running latest 0.8.8 as well as latest march osmc, and I cannot get it to work.

Edit: Checking the cache OSMC has libusb-0.1-4 installed, while xboxdrv uses 1.0-0. Perhaps there is some conflict between these packages; although 0.1-4 is fixed.

Edit2: Tested another operating system and it is an issue with OSMC itself, works perfectly on the latest Raspbian. Is there any way to remove libusb-0.1-4 and replace with the latest? If that is, in fact, the issue.

Edit3: Replacing the actual library files of libusb-0.1-4 with the versioon 1.0 seems to have fixed it(temporarily), although seems pretty sketchy.

Edit4: Running it with the xpad driver gives dmesg output “xpad_irq_in - nonzero urb status received: -71”. Strange.

I don’t think it is the official variant of it, however lsusb outputs it as Microsoft Wireless Receiver.