Issued with hard drives and Vero4K+

Hi,

I’ve just purchased the Vero 4K+ from your website and plugged it today.

I tried to plug in two working hard drives (not simultaneously) and each time I have an issue :

  • The 3.5 HD (self powered) is not recognized at all
  • The 2.5 HD (not self powered) is lowly recognized but makes regularly a noise indicating that it restarts every few seconds and I can’t launch any video.

What can I do?
Thanks
Gilou

Try connecting just the self powered hard drive - this should work.

You will need to power the other drive or use a powered USB hub.

Thanks for your reply.
I did not try to plug the two hard drives simultaneously. The self-powered one was the only one plugged in and was not recognized.

Upload logs (via MyOSMC log uploader) so that we can see why it may not be showing up

1 Like

To get a better understanding of the problem you are experiencing we need more information from you. The best way to get this information is for you to upload logs that demonstrate your problem. You can learn more about how to submit a useful support request here.

Depending on the used skin you have to set the settings-level to standard or higher, in summary:

  • enable debug logging at settings->system->logging

  • reboot the OSMC device twice(!)

  • reproduce the issue

  • upload the log set (all configs and logs!) either using the Log Uploader method within the My OSMC menu in the GUI or the ssh method invoking command grab-logs -A

  • publish the provided URL from the log set upload, here

Thanks for your understanding.

OSMC skin screenshot:

Here we go. I followed the instructions and here are the results:

  • For the 2.5HDD (not self-powered): the HDD was recognised after a long time and playing, pausing stopping the video took like 10 seconds each time (navigating in the folders is tedious; but the HD is still running and clicking like it was rebooting). I precise that it works fine under OSMC & RPI3.
    The logs are here : https://paste.osmc.tv/timitubuva

Thank you

Would indicate not enough power.

For the 3.5" it looks like there was initially an error but afterwards it was recognized and mounted

Sep 05 10:40:59 osmc kernel: sd 0:0:0:0: [sda] 9767475200 512-byte logical blocks: (5.00 TB/4.55 TiB)
Sep 05 10:41:05 osmc udisks-glue[2449]: SG_IO: bad/missing sense data, sb[]:  f0 00 01 00 50 40 f0 0a 80 00 00 00 00 1d 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
Sep 05 10:41:05 osmc udisks-glue[2449]: /dev/sda:
Sep 05 10:41:05 osmc udisks-glue[2449]:  setting standby to 240 (20 minutes)
Sep 05 10:41:05 osmc sudo[2817]: pam_unix(sudo:session): session closed for user root
Sep 05 10:41:08 osmc udisks-glue[2449]: Device file /dev/sda1 inserted
Sep 05 10:41:08 osmc udisks-glue[2449]: Trying to automount /dev/sda1...
Sep 05 10:41:33 osmc udisks-glue[2449]: Failed to automount /dev/sda1: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Sep 05 10:43:59 osmc ntfs-3g[2844]: Mounted /dev/sda1 (Read-Write, label "Elements", NTFS 3.1)
Sep 05 10:43:59 osmc ntfs-3g[2844]: Cmdline options: rw,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177,fmask=0111,dmask=0000,uhelper=udisks
Sep 05 10:43:59 osmc ntfs-3g[2844]: Mount options: nodev,nosuid,uhelper=udisks,allow_other,nonempty,relatime,rw,default_permissions,fsname=/dev/sda1,blkdev,blksize=4096
Sep 05 10:43:59 osmc ntfs-3g[2844]: Global ownership and permissions enforced, configuration type 7
Sep 05 10:43:59 osmc udisks-glue[2449]: Device file /dev/sda1 mounted at /media/Elements

So you can not go to /media/Elements ?

I can access ELEMENTS but it takes time to mount and navigation within the folders is very slow. I did not have any issue with the very same HDD on Raspberry Pi 3

Pi3 on Kodi v19 (latest update)?

RPi3 on Kodi 18 (I think) everything was working fine
RPI3 on Kodi 19 (after recent major update) - stutter and unsync on some videos but HDD working fine (mount, access and navigation) except on H264 or H265 videos but it’s on the RPI3, not the HDD (reason why I bought the Vero).

Can you try the other USB port on the Vero?
Have you tried another USB cable?
Otherwise it may make sense to try the previous image on the Vero.

I’ll try that and will come back here as soon as I have the results (with the log)

Ok, I tried the HDD on the other USB port and it does not change anything. Here is the log: https://paste.osmc.tv/vapinidalu

I tried with another USB cable, same.

How can I revert back to the previous version of OSMC and its last updates? To see if it changes anything

You can install from osmc.tv/download.

Ok, I downloaded the disk image from november 2020 for Vero 4K on my PC. How do I install it on the Vero? Is there a tutorial online?

[Edit] Nevermind, I found it: Reinstalling OSMC - Vero 4K - OSMC