Issues using VScode remote development on RPi 4 (64bit kernel related?)

I’m trying to use VScode remote explorer to connect to projects running on my RPi4 running OSMC but I’m having issues connecting.

Doing some digging in the error logs led me to this VScode Github thread which suggests the issue is probably related to the fact OSMC is using a 64bit kernel but 32bit userland which results in the 64bit version of node being installed which prevents the VScode server from starting.

The workaround described is to temporarily comment out arm_64bit=1 in /boot/config.txt, install vscode-server and then revert the changes, but when I try that the pi doesn’t boot.

Any suggestions on how I can boot temporarily with a 32bit kernel, it doesn’t need to run Kodi, just need SSH access as a minimum.

My config.txt is stock:


include config-user.txt



If you don’t want to run Kodi – then OSMC probably isn’t the best OS for it.



Sorry if I wasn’t clear, I do want to run OSMC and Kodi as the main function of the Pi but I also host a small website from this Pi which I develop using VScode.

The fix to get vscode-server installed in this scenario is to boot once with a 32bit kernel, install vscode-server, then switch back to 64bit kernel. Therefore I don’t mind if the changes I need to make break Kodi as I will revert back to normal settings afterwards.



I don’t plan to release a 32-bit kernel for RBP4.

As hack – you could copy Device Tree files from the Pi 4 image and use a Pi 2/3 image, but this will give you a suboptimal experience.