Issues when playing 4k video from a remote server on Vero 4k+

I am trying to playback 4k videos that are stored on a remote server. I access my library using the PlexKodiConnect addon. The Vero 4k+ has a wired connection to the internet, and I verified using speedtest that the Vero is able to get my maximum bandwidth (200/200 mbps). I have two separate issues: 1) Stutter when starting 4k video from beginning, 2) resuming 4k video.

Whenever I start a 4k video from the beginning that are on that server, the vero switches to the correct resolution and will stutter and will eventually say “cache 0%”.

The second issue is when I want to resume a previously started 4k video. The vero will switch to the correct resolution, upon which it crashes to a sad face.

1080p videos play fine. Also, Jellyfish 4k videos on a USB drive play fine. The TV is a 2017 Sony 4k model. Playback of 4k video using the TV’s Plex app is also without issue, so I’m guessing it’s a setting I need to change on the Vero. I can confirm that it happens on multiple different video files.

I have uploaded a debug log with verbose logging on for the video component:[redacted]

Can anyone help me out?

Looks like something might be wrong with the audio track of that file.

I highly doubt the file itself is at fault here, as I’ve tried multiple videos.

Did you try playing the file from a USB drive?

You might try the Plex add-on and see if that does better than PKC.

I would need to check again but the OP has an SMB mount. I’d recommend trying that mount directly and effectively bypassing the add-on.

I do have an SMB mount, but that’s not where the videos are stored. They are on a remote server, outside of the local network.

@darwindesign: I did try the Plex add-on, but I experience similar issues. Also tried Emby, but similar issues.

When playing the video directly through SMB, playback is smooth, but seeking will result in a crash nonetheless. I have uploaded a log:

If seeking results in a crash, then the video probably has a TrueHD track. This is unfortunately a Kodi bug.

If playback works smoothly via SMB then the issue is caused by Plex or the Plex integration add-on that you are using


The fact the Vero and Emby are both suffering suggests a network issue of some sort - my guess is the effective bandwidth between the remote server and the Vero aren’t up to it. (I’m assuming the TV playback was local than remote server.)

How are you accessing the remote server? VPN? Share or streaming protocol?

Was the speed test between the remote server and the Vero or something else?

1 Like