Issues when updating to the March 2020 release: missing option in My OSMC

I tried to update from the January 2020 release to the March release on an almost vanilla OSMC installation (I only connect one SMB share so that I can copy data from my NAS). During installation, which I manually triggered from the menu, I got this message:

“Error installing: 9-armv6l-eventlircd-osmc (1.4.3) Please report this on the OSMC forum.”

After reboot, when going to My OSMC, there seems to be one icon missing, the bottom left one (between “Pi Config” and “Log Uploader”).

I went went to the “Updates” option again and started another round of updates. It again installed an update, and now I am with version 2020.03-1. However the icon is still missing (at least I am 98% sure that there was one before).

Since my OSMC installation did not require an elaborate setup, I’m perfectly fine to just wipe the SD card and install from scratch. However maybe this is an interesting issue to analyze, so I’m holding on a bit just in case you need me to try something else. Here are the logs:


The SD card shows signs of filesystem corruption.
I would check the integrity of the card and reinstall OSMC.

That was extremely quick - thank you Sam!

I’m not sure what Sam is seeing but that icon was removed on purpose as it was the overclocking settings and there was a bug in it.

Yes – Pi Overclock was deprecated some time ago as it doesn’t make sense for the newer models of Pi

FWIW: just installed from scratch. The installer only puts on 2020.01-1, but the Overclock icon was missing there already. Updating to 2020.03-1 worked without any issues.

So the answer is: the update to 2020.03-1 will remove the Overclock icon if it’s still present (updating to 2020.01-1 and earlier will not do that). And: the SD card indeed seems to be shady, which explains the error message.

The overclock tool was removed some time ago.

sure, but I swear I had the icon in my 2020.01-1 installation (did not try it though) :wink:

No - it wouldn’t have been there