Issues with fkms enabled (HDMI-CEC, no audio, non-working playback) on Pi 3B+


after OSMC update I would like to have a way of controlling it with VNC client (this worked with the previous version). Dispmanx VNC server however requires fake KMS to be enabled in config.txt. Hence I do:

  • in [all] section of /boot/config.txt change dtoverlay=vc4-kms-v3d,cma-512 to dtoverlay=vc4-fkms-v3d,cma-512
  • reboot

As soon as Pi is rebooted dispmanx VNC server is able to start and I can connect to it just fine however different issues appear:

  • it is no longer possible to control Kodi with a TV remote via HDMI-CEC (Lirc buttons do work though)
  • there is no audio (during in-menu navigation and/or playback)
  • video playback stops shortly after start leaving one core 100 % utilized - this is similar to user report at OSMC freezes 5 secs after starting video, CPU >100% - #4 by yusf
  • debug log is flooded with the following recurring messages:
2022-10-22 10:15:45.076 T:867      INFO <general>: CActiveAESink::OpenSink - initialize sink
2022-10-22 10:15:45.076 T:867     DEBUG <general>: CActiveAESink::OpenSink - trying to open device Default
2022-10-22 10:15:45.076 T:867     ERROR <general>: CActiveAESink::OpenSink - no sink was returned
2022-10-22 10:15:45.076 T:866     ERROR <general>: ActiveAE::InitSink - returned error

As part of the troubleshooting I tried to start with a fresh ~/.kodi directory:

sudo systemctl stop mediacenter
mv ~/.kodi ~/.kodi-fkms-backup
sudo reboot

After boot I am presented with the first-boot screen but even there the remote is not working.

Is there a way to have both Fake KMS enabled and working audio/video/hdmi-cec capabilities?

Raspberry Pi 3+ with an up-to-date OSMC.

Thank you,



We don’t officially support FKMS.

This will lead to significant performance regressions