Issues with passthrough and HiFiBerry

Hi,

Try setting Output configuration to best match, rather than optimised.

Thanks Tom.

Hi Tom,
I tried, but it doesnt help. “pass-through output device” option is still disabled, set to HDMI and cannot be changed to my HiFiBerry Digital.

Thanks
Jan

I have the same problem.

I am using OSMC on RPi with HiFBerry Digi board in order to pass-through the audio by SPDIF-Out to my Receiver. Everything has worked great for years, until this last update. Now there is no multichannel sound in SPDIF-out.

Exploring the sound settings in OSMC I discovered that pass-through is now directed to HDMI instead of HifiBerry/SPDIF. Also, my TV is alerting that it detects incompatible sound in HDMI. Unfortunately, the “pass-through output device: HDMI” option is disabled and cannot be changed:-(

Resetting advised by wbeard52 doesn’t work for me.

My log: https://paste.osmc.tv/ebejijowoy

Thanks for any advice!

Hi,

I’ve Moved your posts to a new topic, as I’m not conviced it is the same issue as the OP (sorry messed up post order, been a long day).

If you disable passthrough (for testing), are you then able to change output device?

Thanks Tom.

OK.

When I disable “pass-through” then all the options in this category are disabled as well, including “pass-through output device: HDMI”.

(please, correct the typo in the title, " HiFiBerry" instead of “HiFBerry”, so other people can more easily google this thread)

Thanks
Jan

Hi,

Done (sorry).

Please try the following, you will need to access the command-line:

https://osmc.tv/wiki/general/accessing-the-command-line/

sudo systemctl stop mediacenter
mv .kodi kodi.back
sudo systemctl start mediacenter

If you then able to select the HiFiBerry, then all I can suggest is restore settings and addons one at time, until the cause of the issue is found.

If that doesn’t help, you can restore all your settings:

sudo systemctl stop mediacenter
mv kodi.back .kodi
sudo systemctl start mediacenter 

And we will investigate further.

Thanks Tom.

…thanks, first and the last commands works, but I cannot perform the second command:

“mv: cannot stat ‘.kodi’: No such file or directory”

I really cant see directory .kodi anywhere in the file structure…

Thanks
Jan

Hi,

Try this:

sudo systemctl stop mediacenter
cd /home/osmc
mv .kodi kodi.back
sudo systemctl start mediacenter

Edit:

‘.kodi’ isn’t right it should be .kodi or ‘.kodi’ or even “.kodi”; there is a difference between ’ ( apostrophe) & ‘ (backtick).

Thanks Tom.

…check this screenshot please.

If you don’t have a .kodi directory, and you didn’t already move it then you have a serious problem. If you restart Kodi (mediacenter) it should create a new .kodi directory. If it doesn’t then you most likely have a failing SD card.

…it seems that I have moved it in one of the previous attempts. After restarting the media center, my settings were gone. I checked the audio-ouput settings, put there back the HifiBerry, but in pass-through section, there is still the same problem “pass-through output device:" is set to HDMI and is disabled.

…I really appreciate your help, thanks for your time.:slight_smile:

Jan

… downgrading the OSMC to the previous version seems to be the only solution for me so far.

Jan

Hi Dritst, I was investigating why my audio was suddently always in stereo and it look like I have the same problem as you, I can’t select anything else than hdmi in the passthrough settings. Did you find a solution other than a downgrade? I confirm that a fresh .kodi folder do not resolve this problem. Thanks.

Hello! Unfortunately, I still dont know the solution. I have downgraded to the previous version and I am not installing the updates from that time. Only this way HifiBerry/SPDIF multichannel works for me.:frowning:

Thanks for your feedback. For now my workaround is LibreElec.

Thanks for the hint! I will give it a chance.

Could someone with this problem please post debug logs as the February one has timed out.

Hi

Hopefully the issue is now addressed with the following commit:

I’d appreciate it if you could test this and provide feedback before we potentially release this as an update to other users. To test this update:

  1. Login via the command line
  2. Edit the file /etc/apt/sources.list
  3. Add the following line: deb http://apt.osmc.tv stretch-devel main
  4. Run the following commands to update: sudo apt-get update && sudo apt-get dist-upgrade && reboot
  5. Your system should have have received the update.

Please see if the issue is resolved.

I also recommend you edit /etc/apt/sources.list again and remove the line that you added after updating. This will return you to the normal update channel.