Issues with soundbar 'disconnecting and reconnecting' after August update was applied to my Vero4k+

I’ve started seeing something really weird after I applied the August update to my Vero 4K+

I got a LG TV with a Sky Box, a Sonos Beam Soundbar and the Vero 4K+ connected.

At the moment it looks like the Vero is forcing some kind of disconnect/rescan of the devices that are connected.

If I view normal tv (or something from the Vero) every so often the sound disconnects from the Beam and goes through the TV’s speakers and then back again.

The only way to stop this is to disconnect the Vero - which is sub-optimal if I want to watch anything from it. :wink:

I’ve tried to generate the debug log[1] (with the cec component logging enabled) - hopefully that is of some help.

If I’ve gotten the settings etc incorrect - please let me know and I’ll generate a new one. It’s easy to replicate and I think I saw it happen 3 - 4 times as I was creating this short log.

Thankful for any help/advice!

Cheers, Mike


We prefer to get a full log set instead of just Kodi’s log. Are all three devices plugged directly into the TV? Have you unplugged all these devices from the wall for a minute before plugging them back in which would reset the CEC bus. You might also reseat all the hdmi plugs just in case one of them got a bad connection since in that log it shows Kodi thinking the input changed 20 times. Does this Sky box have CEC? I wasn’t spotting that device in the CEC messaging at all.

Will grab fuil logs later.

Have tried the unplugging, turning off, changing order(ports) of devices, have re-seated all cables in both ends.

Not sure about the Sky Box. It’s a classic HD one - will have to check CEC on that.

In general though - the only thing that has changed was the upgrade of Osmc.

Will return with logs a bit later when I’ve had time to sort that.

Thanks so far!

If that soundbar is using ARC there may be only one port on that LG TV that it can be plugged into without causing incorrect input switching behavior.

Similar issue for me, but way more aggressive and happens while watching Vero 4k. I’m using a Samsung Q990C via ARC. I just applied the latest update and now I’m unable to watch 4k HDR content with Dolby Atmos. Seems to work fine for 1080p without Atmos. It’s just disconnecting the video & audio stream like crazy, the TV behaves as if I’m pulling the HDMI cable in and out.

The same files I was able to watch not a week ago are now just wreaking havoc.

I took some logs trying to play back a 4K HDR Atmos mkv:

I’ve done some more testing and the issue persists. I’ve now taken the full logs as told by @darwindesign . They can be found at:

Things to note:

  • If the Vero 4K+ are connected it will make the soundbar ‘connect/disconnect’ even if nothing is playing via the Vero. Can be watching something via the Sky Box on HDMI 1 and it just keeps on happening. Only way of stopping it is to disconnect the Vero from the TV.
  • I connected on of my RPi4’s running Osmc - same release - to the same HDMI port as the Vero uses and it does not exhibit the same behaviour.
  • The only change in the setup before this started happening was the August upgrade being applied to the Vero. No re-cabling, system upgrades to other parts of the equation have been performed.

Cheers, Mike

Try power everything off at the mains for several minutes.

Meh, that was self inflicting of me. Turns out my ‘insulation tape over pin 13’ hack to battle CEC issues wasn’t as sturdy as I’d presumed it would have been.

I just downgraded to the previous build only to realize it’s not an update related issue to find that out.

Thanks for the help Sam.

I’ve had everything disconnected from mains for ~50 minutes as we went for a walk.

Powered everything back on and the problem reoccurs almost instantly again.

If I set the TV to the Sky input without turning on the receiver I can see the soundbar being selected/deselected (or connected/disconnected) by just watching the volume indicator swapping to/fro.

I’ve submitted a new set of logs[1] after I performed this test.

Cheers, Mike


Can you try the July version of OSMC and see if that restores behaviour in the way you’d expect?

Sorry - have been AFK for a bit. Will give that a go now and let you know how the downgrade worked out.

I re-imaged and restored my backup earlier and so far, I’ve not had a single reoccurrence of the issue.

Since it happened when I wasn’t even watching anything on the Vero I’ll be able to say more this evening. Just had 30 minutes of viewing during lunch - but that should have caused it to happen a number of times if the issue still was there.

Just to follow up. This have now been rock solid ever since the downgrade.