Issues with the netflix app on the Vero 4K +

Hi All

Dont know if this is the place for this (i.e possibly the Kodi forums), but it certainly seems hardware/firmware related, possibly…

So, netflix app generally works, except for the odd title, namely in this case Lucifer S04E03. The vero will try to play the file, then goes back to the gui with the spinning wheel of death, and core #3 goes to 100%. Often the box will crash at this point, or will require a restart to cancel the box trying to play this stream, and to put the cpu back to normal.

Log is:
lots of:
2019-05-24 21:09:16.947 T:3780072160 DEBUG: CAddonSettings[service.upnext]: trying to load setting definitions from old format…

Make sure you have limited playback to 720p


I’ll hide that are if the Vero is selected.

Doesn’t make any difference to this episode, I just had the inputstream settings max for this test as I’d just been watching lightbox. Other episodes in that season play fine with settings as they are.

Sorry I have no idea what you mean by this?

Just tried with my Vero4k, Netflix 0.13.22, Inputstream.Adaptive 2.3.18, pycryptodomex 3.7.0

And Lucifer S04E03 works without issue for me, tried both Max resolution and 720p (on both)

I was replying to a different post, whoops.

pycryptodomex ? Was there anything in my logs to see what’s actually going wrong?

Well pycryptodome 3.7.0 is installed by my script if you used it. If you installed it manually like some other guides do, you would probably get a newer version.

The logging in 0.13.22 isn’t as sophisticated as in .14.x betas, but if you enable debug logs and run the Netlfix add-on and the problematic episode you might get something that tells us what the problem is. Keep in mind I’m not a Netflix add-on developer, and if we can’t solve it here, you’d be better off creating an issue at Netflix add-on github page here.

Yes I did install with your script. I did exactly what you said above - my debug logs are in the first post.

Well those aren’t debug logs,

Settings >System->Logging: Enable debug logs
back to main menu

When it restarts, play a episode of Lucifer S04E01 for 30s, then the broken S04E03.
Back to main menu

Upload logs
Since i got it working i can compare logs and see where it differs.

hmm, ok I’ll try that again… Ahh I think I didn’t do a restart. I’ll also force the stream to 720p to keep that issue out of play.

Couldn’t even play lucifer S04E01 either. (CPU core #3 went to 100% again)

First thing i notice you got HEVC enabled, disable in expert setting in Netflix add-on and try again. This probably the reason for your 100%.

You’re right on the button joakim_s!! that was indeed causing the stall. Still only getting 480P though?

it also doesn’t like vp9 profiles…