January 2020 update install failure

I recently ran the latest January update on my Vero 4K+ and got an installation failure message that “rbp-userland-osmc” package failed to install. After re-boot the system continued to work but did seem a lot more sluggish than before.

I tried to force a re-install of the update from MyOSMC addon but is told me I was up-to-date. So I then tried a forced update through SSH:

osmc@osmc-vero4k:~$ sudo apt-get update
Hit:1 http://security.debian.org stretch/updates InRelease
Ign:2 http://ftp.debian.org/debian stretch InRelease
Hit:4 http://ftp.debian.org/debian stretch-updates InRelease
Hit:5 http://ftp.debian.org/debian stretch Release
Hit:3 http://ftp.fau.de/osmc/osmc/apt stretch InRelease
Reading package lists... Done
osmc@osmc-vero4k:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 rbp-userland-dev-osmc : Depends: rbp-userland-osmc (= 3.1.0-3) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

I then did as suggested …

osmc@osmc-vero4k:~$ sudo apt --fix-broken install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
20 not fully installed or removed.
Need to get 0 B/1200 kB of archives.
After this operation, 5933 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 57992 files and directories currently installed.)
Preparing to unpack .../rbp-userland-osmc_3.1.0-3_armhf.deb ...
dpkg-divert: error: 'diversion of /etc/kernel-img.conf to /etc/kernel-img.conf.distributed by rbp-userland-osmc' clashes with 'diversion of /etc/kernel-img.conf to /etc/kernel-img.conf.distributed by vero3-userland-osmc'
dpkg: error processing archive /var/cache/apt/archives/rbp-userland-osmc_3.1.0-3_armhf.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

Following this, the Vero4K+ will no longer respond through the the UI. Although an SSH session confirms it is still alive and running.

Any suggestions for how I can fix this without having to resort to a system reset?

Many thanks.

How did you get that repository in your sources.list?
You must have included a Raspberry Resporitory on your Vero.

Check your sources.list, it should only be

deb http://ftp.debian.org/debian stretch main contrib non-free
deb http://ftp.debian.org/debian/ stretch-updates main contrib non-free
deb http://security.debian.org/ stretch/updates main contrib non-free
deb http://apt.osmc.tv stretch main

But as you continued with fix-broken you might have broken the system and may want to reinstall

I have installed ‘Retrosmc’ on the Vero4K+ alongside Kodi. Could that account for the missing dependencies? Otherwise, I’m none the wiser.

Where can I find the ‘sources.list’ file? Have looked in ‘sources.xml’ and found nothing Pi specific in there.

/etc/apt/sources.list but it might also be that you have something in /etc/apt/sources.list.d/

I hope you installed the Vero Version retrOSMCmk2!

I think OP installed the Pi version

Yes I did. Only installed retrOSMCmk2.
Does the OSMC update cater for that? Or is it independent?

This still is odd, suggest to upload logs via grab-logs -A so that we can check what is going on.

OK. Tried uninstalling retrOSMC which made no difference.

Have uploaded logs to:
Logs available at https://paste.osmc.tv/omidodiqig

Thanks for your help.

BTW, when I first went to the MyOSMC addon to try to force an update (after the initial failure) I noticed the the “Pi Config” option had appeared as an option that I’m pretty sure was not there before.


I think this may have been what caused the issue:

Start-Date: 2019-12-23  14:25:09
Commandline: /usr/bin/apt-get-real install -y --no-install-recommends libsdl1.2-dev rbp-userland-dev-osmc

possibly wanted vero3-userland-dev-osmc instead?

Could try this as a fix, if this fails I’d recommend reinstalling.

sudo apt-get purge rbp-userland-dev-osmc
sudo apt-get update
sudo apt-get dist-upgrade

If that fails, install is the way forward:

Thanks Tom.

So you corrected your sources.list before uploading your logs?
If so then try the steps @Tom_Doyle wrote.

1 Like

Thanks Tom. That appears to have done the trick. I now have my system back up and working. :grin:

1 Like

I didn’t correct my sources.list before uploading the logs. (As I couldn’t find it.)

But all sorted now, thanks to Tom’s suggestion.

Thanks all.

Ok, we actually had a chat in the background. I misread the original output. So your sources were not wrong that was just the resolving of a local mirror.