January update now iqaudio dac not working?

i’m using es9023 dac on rpi2 with osmc
I’ve made settings like below :

sudo apt-get install alsa-utils

sudo nano /etc/modules

Adding the content below, store them by “Ctrt+X” and then withdrawl


sudo reboot

In Settings > System > Audio Output I can select** ALSA: Default(snd_rpi_gifiberry_dac Analog)** but at this moment system is hangs.

who can help me .thanks.

I assume your issue is not related to the thread topic (otherwise it would already be solved) so suggest you open a new thread

1 Like

Since Raspbian 4.4.14+ the following entry is necessary in /boot/config.txt:


To remove the standard Raspberry PI audio card, add


The last reply to this post is over eight months old

OSMC still uses the wrong statement


which does NOT work with the IQAudio devices. The IQAudio Pi-DigiAmp+ does not work out of the box with OSMC.

Please, use


instead. Fiddeling around with GPIO 22 isn’t necessary anymore since Raspbian 4.4.14+

Will adjust, thanks.

Just to clarify: did you configure via My OSMC’S Pi Config? Which version are you using?

We will adjust DT to be more conforming with upstream soon, which will make -overlay necessary


I used the OSMC-installer today. If I remind well the newest version was 2016-09-xx.

I also did some additional tests. You can use




but you have to append


to unmute the power-amplifier circuit.

I’ll ask Gordon at iqAudio about this. It seems strange the board would need the additional parameter just to work out of the box. If this is the case, it’s certainly something that can be improved

The IQAudio power amps are muted by default in hardware. Until Raspbian 4.4.14 it was necessary to unmute the power-amp with a shell command. Since Raspbian 4.4.14 it is possible to use the device-tree statement. Have a look at section 12 of the IQAudio User Guide.

Thanks for this.

I am actually working with Gordon on producing images that work with the DAC out of the box.

I thought ALSA had to be used to unmute the mixer. I was exploring a kernel patch to address this. Being able to do this via device tree is handy. Thanks for bringing this to my attention.


I know that this is an old (one year) thread, but with the january update (2018) I suddenly have no sound from my IQaudio DigiAMP+. Everything looks correct, but suddenly I have no sound what so ever.

Any others with similar issue, and more importantly anybody with suggestions to how I can debug this.

If nothing else I will try another fresh image on it and see if there is sound then (or even worse it is hardware failure…)

edit: moved to [SOLVED] IQaudio no sound after january 2018 update

Can you please start a new post with some logs?


1 Like