Jerky GUI on Vero 4k+ file library

https://paste.osmc.tv/zafodukacu

This log is a month old, but unchanged.
I had already a chat with Sam a month ago.
He told me clearing the Kodi database which didn´t help.

It has only to do with the Remotes section under MyOSMC.
Only by opening this and going back did the trick.

Maybe i´m the only one who notice this :roll_eyes:

I see that your remote is not being seen as a keyboard (as it currently should) until after you open the My OSMC add-on. There is also a system keymap that doesn’t look quite right. I would recommend backing up Kodi with My OSMC, Perform a clean OS install, and then restore Kodi from the backup.

Hm, thats strange. I have always made a clean install without backup anything. Nor didn’t i change anything about keymap or remote. I could try once more, but i’ m sure it doesn’t change anything because i had made a clean install bevor i postet the log a month ago :thinking:

It wasn’t completely clean as this wouldn’t be there without activating it…

====================== lircd.conf =================== kdgLUcwP
   ...
# brand:                     OSMC
# model no. of remote control:
# devices being controlled by this remote:
   ...
---------------------- lircd.conf END --------------- kdgLUcwP

Which i’m sure someone here who knows more about eventlircd than I do could tell you how to remove it, but since i’m also seeing this…

LoadMappings - loaded node ""

It’s making me think there might be more going on. You don’t have to backup and restore anything if you don’t want, but as your issue seem to come from the system files, and the My OSMC add-on backup is just Kodi, I think you can get rid of your problem without going through the hassle of starting from scratch with your setup and Library.

Maybe i should try an older version bevor january and see if that can help.
Installing from scratch isn’t a problem for me. I’ll post a new log.

An older version is going to be completely different as we have recently transitioned from using eventlircd to keyboard input to providelong-press support. Your issue appears to me that it is using the old method (why I don’t know) until you open My OSMC, which it should not be doing.

should i try the recovery mode (pressing the button on the back side with a pen) for reinstalling ?

No, just follow the normal directions. The recovery mode is only for when something goes wrong and the normal method isn’t working.

I have now made a fresh install. Nothing changed. I haven‘t yet installed my library.
I can only get a relatively fluid GUI experience when i first open Remotes and nothing else under myOSMC. Anybody else must experience the same except my vero4k+ has an other hardware.

It is more noticable by turning of slide animations and background images.
Perhaps the gui needs more power.
I need the next vero :wink:

I remember your ticket but can’t think of anything that could cause this.

Are you trying with the OSMC skin?

Sam

You have a jeky UI with no artwork or library? You turn off animations and fanart and it gets worse? Is there any way for you to take a short video of this with a cell phone of something and post a link to where we can view it?

EDIT: This may be a bit of a long shot but can you plug the Vero directly into the TV and verify it still does the same thing?

No, not more worse, only more noticeable in the better direction, smoother. If slide animation and background pictures turned off it gets better. The GUI seems to be very hungry. Go to myOSMC, open Remotes and then just scroll over the osmc logo in the center. It beheaves more fluidly, open an other icon and try again, it becomes jerkier. And this is also unter the osmc and kodi standard skin.

Could you record a Video using the OSMC Skin to show this behavior as I have never seen this happening (I am not using an IR Remote). Maybe record from reboot showing the jerky gui and then the smoother after going to the remote section.

I just started noticing this as well.
Very jerky especially when scrolling fast through movies.

Does your issue go away when you open the remote section of My OSMC as well?

I´ve tried rcording with my iphone, but the effect isn´t so much noticable on the handy video.
I´ll try with a keyboard.

@Kontrarian Please, provide a short recorded video snippet and logs, so we can see what you mean and compare with @maxx’s issue.

Can you check your TV’s settings for any kind of sports mode or other motion smoothing settings, disable them, and then check to see if your issue is still there.

We are talking about a visual issue and not an issue with responsiveness of the remote aren’t we? If so what is using a keyboard suppose to change?

Yes visual issue.

I´ve all picture enhancer disabled on my tv.

Can you please go to myOSMC and chosse the OSMC icon i the middle, and notice the stuttering flip.
Than open Remotes, leave Remotes and choose the OSMC icon again.
It flips without stutter, and the same behavior is noticeable unter de kodi and osmc skin as well.

Perhaps most people didn´t notice this, but it feels much smoother for me.
BTW, if i turn background picture and slide animation of, thats to much for such a little device.