Jerky video playing, especially with HiFiBerry DAC+


I switched a few weeks ago from Openelec to OSMC on my Raspberry Pi B+ and everything worked fine for a time, even with my HiFiBerry DAC+ that I never succeeded to got working on Openelec.

But a few days ago playing movies became suddenly totally sluggish.

The pi is connected to an amplifier trough RCA and to a projector trough HDMI. The files are read trough a SMTP share. Nothing changed on this side of the installation.

With the HiFiBerry DAC+ analog output the sound is good (there was a few slow-down or pitch drops time to time, when starting or moving the timeline, but no big deal), but now during playback the video is totally jerky, and never reach 12 fps or so. I configured the DAC+ by following . This is sadly unusable and I had to disable it for now.
But even with the pi analog output (where the sound is not so good, as it always been, especially a continuous loud white noise) there is now also regular frame drops, for a second every 10 seconds…

The issue apply to any of the files I tried.
Everything seems stable apart from that, and relatively fast during other tasks.
The CPU is overclocked to 950 (using the preset), and is around 20% in idle and fixed at 100% during playback.

The only two things that changed in the previous days, as I remember, is that OSMC was upgraded to the last release, and that I installed a vnc server. The vnc server is idle when not used, with a very light footprint on the CPU, and I didn’t see any improvement by killing it.

I’m fighting with that for the last days and I’m a bit lost, please tell me if I should have added any other information.

Thanks a lot for your consideration.

PS : the only other thing that I noticed become slower is the search for subtitles on OpenSubtitles, that takes at least 20s with OSMC. But I presume that it’s unrelated.


First thing, please ensure that you’re on the latest version


Hi Sam,

Thanks for your reply !

I didn’t find an official latest version number, but if the last blog post correspond to a released version I may have a previous one.

uname -a
Linux osmc 4.2.1-1-osmc #1 PREEMPT Wed Sep 23 20:52:02 UTC 2015 armv6l GNU/Linux

If I try to update trough OSMC I get an error. I cannot upload logs trough My OSMC either (the page indicated in is broken, but anyway I cannot use paste-log or grab-logs either).

I’m currently trying to do a dist-upgrade.

I managed to upgrade and videos seems to be fluid. I didn’t had time to try deeply however.

I still don’t know what happened, if it may happen again, and if I did something wrong to avoid. Some upgrade issues were due to insufficient disk space. May the sluggish video playback be related to system disk space ? Or was it a system issue resolved by the upgrade ?

The initial September update accidentally included a debug build of Kodi which would slow things down a lot and also write huge Kodi log files, we got a fixed version out as an update a couple of days later, that’s why updating again would have solved it for you.

Hi DBMandrake,

It seems to be exactly what happened.
Indeed I noticed yesterday when upgrading that the .kodi/temps/kodi.log was several hundreds of Mb big, and in my case the system have filled the disk space just enough to defeat any upgrade process, preventing the fix of the initial issue.

I’m relieved to hear such a neat explanation.

Thanks all for your good work !