Jittering movements on some H.265 streams on DVB-T2

Hi Sam,

any news about solution of this problem?

thx Lada

Jirka today starts new Sport5 station by Digital Broadcasting. For me it seems to be good (no jittering), can you confirm?

Please test with our 4.9 test builds which will be available shortly.


It seems a little bit better but stil present.

Are you able to test with our 4.9 release?

I would like to but my Vero is still under warranty.

The 4.9 test build does not void your warranty.

Glad to hear that. I will let you know result :wink:

I tried to test new kernel but there is no support for osmc dvbt2 dongle. Probably I have to compile new kernel with support ?? Thanks

Message from dMESG.

[70222.440717] usb 1-2: new high-speed USB device number 3 using xhci-hcd
[70222.590723] usb 1-2: New USB device found, idVendor=15f4, idProduct=0131
[70222.590732] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=                                0
[70222.590737] usb 1-2: Product: dvbt2
[70222.590740] usb 1-2: Manufacturer: astrometadvbt2
[70222.598952] usb 1-2: Unsupported device
[70222.600876] usb 1-2: Unsupported device
[70222.641677] usb 1-2: dvb_usb_v2: found a 'Astrometa DVB-T2' in warm state
[70222.716110] usb 1-2: dvb_usb_v2: will pass the complete MPEG2 transport stre                                am to the software demuxer
[70222.716144] DVB: registering new adapter (Astrometa DVB-T2)
[70222.728082] i2c i2c-0: Added multiplexed i2c bus 1
[70222.728092] rtl2832 0-0010: Realtek RTL2832 successfully attached
[70222.733488] i2c i2c-0: cxd2841er_attach(): I2C adapter ffffffc05c0d00b8 SLVX                                 addr 6e SLVT addr 6c
[70222.733499] cxd2841er: I2C data: 00000000: 00                                                                               .
[70223.011685] i2c i2c-0: cxd2841er: i2c rw failed=-11 addr=6c reg=fd
[70223.011694] i2c i2c-0: cxd2841er_attach(): invalid chip ID 0x00
[70223.011714] dvb_usb_rtl28xxu 1-2:1.0: CXD2837ER attach failed!
[70223.021291] dvb_usb_rtl28xxu 1-2:1.0: Sony CXD2837ER detached automatically.
[70223.022445] usbcore: registered new interface driver dvb_usb_rtl28xxu
[70228.713066] wl_run_escan: LEGACY_SCAN sync ID: 7024, bssidx: 0
[70238.709030] wl_run_escan: LEGACY_SCAN sync ID: 7025, bssidx: 0

I will fix this shortly.

Sam, I found latest 4.9.113-14-osmc kernel build much better and stable when i play live TV via dvbt2 dongle. It looks problems with stuttering are gone. But it will need further testing.

I have recorded short clips from TV(before upgrade kernel) and those still causing stuttering when i played them in KODI with AMLVIDEO acceleration ON. Without acceleration are OK. Tested on PC VLC and ok. Here they are if you want to test them yourself. If reencode them to HEVC 8bit there are played fine. So it seems to be specific to file format MPEG-TS??


If it’s solved in 4.9, then we don’t need to fix it for 3.14.


@sam_nazarko it’s back. Today i tried live tv channels which made these problems and jittering is back. I´ve uploaded short clip.

I am on latest kernel.


Here is the log file

What version did it work well on before?


But i tested it shortly. Hope it helps.

You can test the newer kernel shortly

Did you try play recorded stream on your VERO??

I downloaded ‘TVJOJ.ts’.
I can check it for you tomorrow.

Thanks, it’s strange that Just a few cases were reported.

Any update? Did u try play that file??