Jittering movements on some H.265 streams on DVB-T2

Hello, I’ve very specific problem with some HEVC streams from DVB-T2 in Czech republic.
The movements are - how to say - jagged, shaded, pixeladet edges, someting like partial “ghosts”.
I can provide a recording. I have following observations:

  • The problem occurs only on particular streams on one particular DVB-T2 multiplex (MUX24 in Czech republic). And not always.
  • It is not problem of a poor signal from antenna (perfect signal strength and quality)
  • If I record the affected stream, the problem occurs also while its playback on Vero and the artefacts are always the same
  • The recording is playable on PC (VLC player) without problem so stream is not “damaged”
  • When I connect to Vero’s TVheadend server from PC version of Kodi (as client) the problem doesn’t occur, so I think that there is no problem with DVB-T2 signal nor TVheadend
  • Similar problem is observable on my other TV box Tesla TEH-500 (Android, also with Amlogic chipset)
  • It seems like some postprocessing problem of videostream - maybe incorrect deinterlace etc.
  • Stream info (from ffmpeg):
    Stream #0:0: Video: hevc (Main), yuv420p(tv, bt709), 960x540 [SAR 1:1 DAR 16:9], 50 fps, 50 tbr, 1k tbn, 50 tbc (default)
  • All other H.265 content is played correctly by my Vero.

It seems like these particular streams contains something wrong that is not 100% compatible with Amlogic HW decoding of HEVC.

Could you provide any clue how to solve this, please?

I use latest upgrade of OSMC, with Vero 4k. Output set to 1080p50 (but doesn’t matter).

Hi,

Sorry for the late reply. I’ve been travelling so I’m only just getting back on top of things.

This doesn’t necessarily mean the stream is damaged. VLC may be using software decoding which could be more tolerant.

Can you provide a small recording of the stream as well as some debug logs? MediaInfo of any affected files would also be helpful

Thanks

Sam

Hello, yes. The example recording (short but the problem is clearly visible while playing on my Vero 4k). https://uloz.to/file/GcTJTVO5zyYH/recording-ts.
I’ll send debug logs later (now I am not at home).

Hello again, the debug log while playing the recording.ts file (above) is following: http://paste.osmc.tv/dibusosasa.vhdl

I have the same problem. But I haven’t tried it on another device, that’s right. Are you sure that problem is MUX24 not Channel 24 from temporary MUX 13?

Same problem here. It looks like picture distortion when is played in kodi player. I tried Jirka’s recording and is reproducible.

I have another question, is there way to see signal strength, SNR and PER on osmc dvbt dongle??

Does it only happen with this channel?
Are you all Czech?

I am from Czech republic and Jirka are you really sure, that it is MUX24? It is the final MUX. I have those problems on channels from MUX13.
mux13

Yes, I am from Czech rep too. The problem is occuring only in MUX24 (operated by Digital Broadcasting), but I remember that the problem was also in temporary MUX13 (operated also by Digital Broadcasting, very similar content). The problem occurs on almost all programs in this mux.

Other czech DVB-T2 muxes (operated by other operators) are not affected and are played perfectly by Vero.

The problem is not Vero4k specific, for me it occurs also on my Tesla TEH-500 Android box (also Amlogic chipset - so my opinion is that there is something non-standard in this mux that is not 100% compatible with Amlogic HW decoder). I haven’t seen this problem on cheap DVB-T2 set-top-box (unfortunatelly I don’t know what device it was).

Also Czech rep. :blush: But maybe found a solution. It looks tvheadend cant automaticaly set right. Can someone try settings for mux 13 below??

Settings works for me.

Maybe you got it! https://www.videotvsat.cz/clanky/dvb-t-pozemni-prijem/dvb-t2-multiplex---prechodova-sit-13.html confirm your theory. I will try it on MUX13.

So confirm that tvheadend setting from link above and your screen for MUX13 on Czech republic helped. Topic solved in my opinion. What about jirkav7?

No, it’s still the same (for MUX24 - we have already the final mux near Prague).
I am unable to set FEC low to NONE. And when I set the PLP ID to -1 the mux stops working at all (PLP ID must be set to 0 for me).
I still think that the problem is not in DVB-T2 receiver. If I connect to Vero’s TVHeadend from regular notebook PC (Windows + Kodi for windows or VLC), the TV programs are played correctly. So the DVB-T2 tuner is tuned properly).

you are right :frowning: today it is the same. It does not helped.

Yeah today same for me. It must be player related. Recorded stream is played in vlc MX player etc without glitch. In kodi is picture corrupted.

Found, If you turn off hardware acceleration. Picture is ok. So there is something causes this curruption.

I did not touch anything and tried that again. I was surprise that it was good (January update?). So I watched TV, then switched to another channel and after half minute switched back to problematic ones and it happend again. So sometimes it is OK, sometimes not. The true is, that after that I tried to switch channels back and forth and this no longer helped.

Bary can u try to turn off hardware acceleration in kodi settings and try if picture is ok?? Thanks

Hello, I’ve tried to turn the AMlogic HW acceleration on my Vero. The problem disappeared (on affected TV channels / recording). But the Vero has not enough CPU power for smooth playback of FullHD HEVC video (1920x1080) without HW acceleration. qHD (960x540) is OK. So I think that we have confirmed the hypothesis, that the problem is in somewhere in Amlogic HW accelerated decoding of HEVC video.

I think about some workaround - is there any possibility how to configure Kodi to use SW decoding on low-resolution (eg. 960x540) HEVC videos and use HW decoding on FullHD videos? Because the problem occurs only on MUX that is broadcasting only qHD streams. Maybe somewhere in advancedsettings.xml?

Edit: I’ve found that SW decoding would not be a solution because some qHD streams (possibly with higher bitrates) are not playable smoothly without HW acceleration

Can someone send me a recording via another service? I’m having difficulties downloading the link previously posted.

I want to get this fixed promptly.

Sam

Please try this link: https://en.webshare.cz/#/file/2q3db1zN2J