Judder on 1080p file

I am experiencing some judder or stutter on a 1080p file. If I show info during playback I am not seeing framedrops/skips strangely. Especially in panning shots its very much “not fluent”, but also people walking seem to have issues with their pace.

Logfile (rebooted twice and uploaded via OSMC menu): https://paste.osmc.tv/hutimibope

  • Adjust display refresh rate is set to: on start stop
  • I tried Sync playback to display, doesn’t help (my default is off for passthrough audio)
  • I tried disabling audio passthrough, doesn’t help
  • file plays fine on my laptop and on kodi on a “mi box s”
  • it is not happening on all files, just this tv show and another tv show I have

With info enabled I see no drops or skips at all. I do see a negative value for VsyncOff of more than -10 (eg. -16,7, fluctuating).

I also replaced my HDMI cable recently due to another issue. 4K is playing fine now and I assume this file is not heavy enough to cause issues with this HDMI cable?

I tried to send a part of the file to a friend to see if he can play it. I used mkvtoolnix to chop the file into 100 MB sizes and strangely those small files play fine which really puzzles me - what could explain that? perhaps there lies a clue to the solution.

Any clues on what I can try to solve are appreciated.

file specs
Unique ID : 178002605302482970644697152665291275165 (0x85EA0E059C1EACFB42E785667CB73B9D)
Complete name : U:\Series\Those Who Kill\Season 01\Den.som.draeber.s01e05 s01e06.Danish.1080p.Web-dl.DD5.1.x264-NDF.mkv
Format : Matroska
Format version : Version 4 / Version 2
File size : 2.47 GiB
Duration : 1 h 25 min
Overall bit rate mode : Variable
Overall bit rate : 4 126 kb/s
Encoded date : UTC 2021-10-22 11:43:48
Writing application : mkvmerge v62.0.0 (‘Apollo’) 64-bit
Writing library : libebml v1.4.2 + libmatroska v1.6.4

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L4.1
Format settings : CABAC / 3 Ref Frames
Format settings, CABAC : Yes
Format settings, Reference fra : 3 frames
Format settings, GOP : M=3, N=50
Duration : 1 h 25 min
Bit rate mode : Variable
Bit rate : 3 740 kb/s
Maximum bit rate : 7 200 kb/s
Width : 1 920 pixels
Height : 1 080 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 25.000 FPS
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.072
Stream size : 2.24 GiB (91%)
Title : Nordicflix
Language : English
Default : Yes
Forced : No

ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Commercial name : Dolby Digital
Codec ID : A_AC3
Duration : 1 h 25 min
Bit rate mode : Constant
Bit rate : 384 kb/s
Channel(s) : 6 channels
Channel layout : L R C LFE Ls Rs
Sampling rate : 48.0 kHz
Frame rate : 31.250 FPS (1536 SPF)
Compression mode : Lossy
Stream size : 235 MiB (9%)
Title : 5.1
Language : Danish
Service kind : Complete Main
Default : Yes
Forced : No

I would suggest remuxing the file to see if this helps.

1 Like

Thanks. Remuxed the full file, full remuxed file has stutter. Have been playing the original file, remuxed file and short remuxed file over and over. Had one instance where the original played ok. And now the small remuxed file also has shown judder although less often compared to the large files with play bad approximately 2 out of 3 times. Is there some sort of buffer somewhere that fills up and is persistent between playbacks? really weird.

Will Check again on mi box s with multiple tries to see it was not a lucky shot on that device.

Update: played the file 8 times on the mi box S and plays fine there. As said it is a panning shot so motion is blurry. However consistently blurry.

Playing on the vero its like I get a small pause, then three frames, then a small pause. Hard to explain but the speed the camera moves is not consistent. Fast, slow and that’s why I notice it.

Nope – have you tried playing it from local storage to rule out a throughput issue?

1 Like

Good suggestion. Plays fine from USB, tried 12 times as I was so surprised that works.

Puzzled as the file is 2.47 GB for a show lasting 1hr 25 mins in 1080p
Tried a 4K file (39GB for 2 hr movie) and that plays fine, so why can my setup handle that and not the other one…

Using a Synology Nas, smb3, one gigabit switch inbetween. Everything connected with cables. My Mi Box S uses wifi and has no issues so never thought to consider the network in any way.

Also noticed I had the “fix smb2 MTU issue” switch enabled - disabled it and doesn’t have any impact.

There’s some performance improvements for SMB shares (if accessing via Kodi and not fstab / autofs) in the next update.

That might do the trick.

1 Like

Thanks. Any hint when the next update is due?

Would mounting via another way than SMB improve speed and stability as well?


Tomorrow, and yes, it would, but you might not need it.

1 Like

You could try using autofs, maybe? (Assuming you aren’t already either using it or using fstab).

I suggest not using a credentials file as a first pass.

1 Like

The update is now live.



1 Like

Thanks Sam! Updated this morning and playback is now buttery smooth again! I even played it 10 times just to be sure. Consider this solved, appreciate the quick response.

Still a bit curious what was fixed, is there a thread on that somewhere? Simply curious as buffer was always 100%, no drops and skips and far larger 4K files still played fine so my noob assumption is throughput on the network was ok.

Glad to hear this. There’s been a couple of changes so it may not specifically be SMB.