July update error

hi Guys!

I just tried to install the july update, and i’m stuck at a screen:

OSMC Update Error.

Error installing:

Please report this on the OSMC forum.

If i can help providing any further data, please let me know.

FYI when i tried to update it via command line, i get this:

Fetched 688 kB in 24s (28.2 kB/s)
W: Failed to fetch http://ftp.debian.org/debian/dists/jessie/main/i18n/Translation-en Hash Sum mismatch

E: Some index files failed to download. They have been ignored, or old ones used instead.

aand boom.

are you sure guys all ok with this update?

openssh-servererver-osmchile processing:eder (–configure):3); however:ever:.16
E: Sub-process /usr/bin/dpkg returned an error code (1)

/var/cache/apt/archives/rbp-userland-osmc_1.2.0-6_armhf.deb…] Er
E: Sub-process /usr/bin/dpkg returned an error code (1)

osmc@osmc:~$ sudo apt-get update&&sudo apt-get dist-upgrade Ign http://ftp.debian.org jessie InRelease Hit http://security.debian.org jessie/updates InRelease Hit http://ftp.debian.org jessie-updates InRelease Hit http://ftp.debian.org jessie Release.gpg Hit http://ftp.debian.org jessie Release Hit http://apt.osmc.tv jessie InRelease Hit http://security.debian.org jessie/updates/main armhf Packages Get:1 http://ftp.debian.org jessie-updates/main armhf Packages/DiffIndex [5440 B] Hit http://security.debian.org jessie/updates/contrib armhf Packages Hit http://ftp.debian.org jessie-updates/contrib armhf Packages Hit http://security.debian.org jessie/updates/non-free armhf Packages Get:2 http://ftp.debian.org jessie-updates/non-free armhf Packages/DiffIndex [736 B] Hit http://security.debian.org jessie/updates/contrib Translation-en Hit http://ftp.debian.org jessie-updates/contrib Translation-en Hit http://security.debian.org jessie/updates/main Translation-en Hit http://security.debian.org jessie/updates/non-free Translation-en Get:3 http://ftp.debian.org jessie-updates/main Translation-en/DiffIndex [2704 B] Get:4 http://ftp.debian.org jessie-updates/non-free Translation-en/DiffIndex [736 B] Hit http://ftp.debian.org jessie/main armhf Packages Hit http://ftp.debian.org jessie/contrib armhf Packages Hit http://ftp.debian.org jessie/non-free armhf Packages (Reading database ... 29132 files and directories currently installed.) Preparing to unpack .../armv7-network-osmc_1.6.3_armhf.deb ... Hit http://ftp.debian.org jessie/non-free Translation-en Get:5 http://apt.osmc.tv jessie/main armhf Packages/DiffIndex [2023 B] Ign http://apt.osmc.tv jessie/main Translation-en Fetched 11.6 kB in 22s (512 B/s) Reading package lists... Done Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done The following packages will be upgraded: armv7-network-osmc base-files-osmc rbp-userland-osmc 3 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 5 not fully installed or removed. Need to get 2108 kB of archives. After this operation, 529 kB of additional disk space will be used. Do you want to continue? [Y/n] Y Get:1 http://apt.osmc.tv/ jessie/main armv7-network-osmc armhf 1.6.3 [3984 B] Get:2 http://apt.osmc.tv/ jessie/main base-files-osmc all 1.9.6 [15.4 kB] Get:3 http://apt.osmc.tv/ jessie/main rbp-userland-osmc armhf 1.2.0-6 [2089 kB] Fetched 2108 kB in 0s (2864 kB/s) /var/cache/apt/archives/rbp-userland-osmc_1.2.0-6_armhf.deb................] Er E: Sub-process /usr/bin/dpkg returned an error code (1)

Why wouldn’t we be sure? You seem to be the only one having a problem. Provide grab-logs -a

or just the first one :slight_smile:

Anyway, thanks for the help… I can’t even run this command. Tried to provide some kind of log, but didn’t run, it was showing just an error.

What error? If you can’t successfully run the logging command then that would seem to indicate some larger issue at play here.

We’re not aware of any issues with this update. It looks like your SD card may be corrupted.

Check your power supply and SD card.

thanks Sam.

Will do a reinstall.

1 Like

Had the same message pop up when trying to install the update. Said it was going to try and restart Kodi in 30 seconds, which it did, and everything seems to be working as it should once it rebooted.


Hi I am still getting the same error message popping up. Any ideas what is causing it? Thanks