Just receiver new vero 4k

Just got a new vero 4k from friend to test and play with

brand new -> the remote doesnt work, tried everything, got rid of plastic, tried other brand new battery, tried different usb port, attached ir extender, nothing helped
guess the usb receiver is dead? (i can see the remote has a small blue light light up as soon as i press button… so i assume its the usb receiver?

Attached my own usb mouse remote, it works immediately

installed vero 4k with basic kodi looks, instead of the omc looks

eveything going well but, now it comes

i use zoom to fill my 21:9 screen
so i need a special kodi skin
tried installing it, but it doenst work

Sam can you look into this pls
see: GitHub - Funkd/ScopeNox: Scope version of Aeon Nox

Skin isnt that heavy at all, works on zidoo x9s, intel nu , all other kodi hardware except vero 4k

You have already posted this over on the Kodi forums, and PM’d it, so I’ve replied there.

Please can we keep the correspondence in one place so it is easier to address your issue.